Trabajar con ESERROR y COINCIDIR en diferentes hojas

6 envíos / 0 nuevos
Último envío
Neferet
Imagen de Neferet
Offline
última acción: Hace 7 años 7 meses
alta: 14/03/2013 - 15:14
Puntos: 40
Trabajar con ESERROR y COINCIDIR en diferentes hojas

Quiero comparar dos listas de datos de diferentes libros. Utilizo la formula =SI(ESERROR(COINCIDIR('[rechazo.xls]HOJA1'!A45;FINAL!A2:A114;0));"";'[rechazo.xls]HOJA1'!A45), Y NO ME FUNCIONA. Si realizó la misma opración entre hojas del mismo libro la fórmula funciona perfectamente. ¿Qué debo hacer?

 

Gracias

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 17 horas 17 segs
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Prueba sin comillas

Prueba quitando las comillas simples

Excel pone comillas simples sólo cuando en el nombre de la hoja hay espacios o cuando el libro al que te refieres está cerrado, en ese caso pone la ruta entre comillas

en tu caso entiendo que tienes el libro rechazo.xls abierto, por eso no hace falta la ruta, y tampoco tienes espacios en los nombres de las hojas.

 

si creas las fórmulas de cero seleccionando los rangos con el ratón, Excel ya se ocupa de poner o no las comillas y no debes preocuparte de esto.

 

Ejemplos:

nombre sin espacios, no hay que poner comillas

=SI(ESERROR(COINCIDIR([Libro2.xlsx]Hoja1!$A$1;FINAL!A1:A21;0));"";[Libro2.xlsx]Hoja1!$A$1)

 

pero si los nombres de las hojas tienen espacios, entonces aparecen las comillas:

=SI(ESERROR(COINCIDIR('[Libro2.xlsx]nombre de hoja con espacios'!$A$1;FINAL!A1:A21;0));"";'[Libro2.xlsx]nombre de hoja con espacios'!$A$1)

 

con el libro cerrado (aparece la ruta), Sí pone comillas simples

=SI(ESERROR(COINCIDIR('C:\Users\xxx\Documents\[Libro2.xlsx]Hoja1'!$A$1;FINAL!A1:A21;0));"";'C:\Users\xxx\Documents\[Libro2.xlsx]Hoja1'!$A$1)

 

 

------
Ya sé Excel, pero necesito más.

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Re: Trabajar con ESERROR y COINCIDIR en diferentes hojas

A veces estas fórmulas solo funcionan si tienes abierta la otra hoja.

 

Otras veces necesitas la ruta completa del archivo, tipo "[c:\Documents and settings\user\mis documentos\libros de excel\rechazo.xls]"

 

Prueba ambas soluciones y nos vas contando, a menos que alguien tenga otra solución mejor.

 

 

Saludos

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Re: Trabajar con ESERROR y COINCIDIR en diferentes hojas

Veo que mientras me lo pensaba, ahí estaba Paco al quite ;)

 

 

Saludos

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 17 horas 17 segs
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Re: Trabajar con ESERROR y COINCIDIR en diferentes hojas

vamos a tener que establecer turnos

 

------
Ya sé Excel, pero necesito más.

Neferet
Imagen de Neferet
Offline
última acción: Hace 7 años 7 meses
alta: 14/03/2013 - 15:14
Puntos: 40
Re: Trabajar con ESERROR y COINCIDIR en diferentes hojas

Gracias por contestar rapido, he probado otra vez, y TODO PERFECTO

Guiño