Seleccionar rango, copiar y pegar hasta la ultima fila

3 envíos / 0 nuevos
Último envío
Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 11 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Seleccionar rango, copiar y pegar hasta la ultima fila

Buenas tardes:

Manejo el siguiente código:

 

Range("a3").FormulaLocal = "=SUBTOTALES(103|$F$3:F3)"
Range("a3").AutoFill Destination:=Range("a3:a" & Range("f" & Rows.Count).End(xlUp).Row)
Range("b3").FormulaLocal = "=SI(ColorFondoIgual(E3|204|255|255)|""X""|)"
Range("b3").AutoFill Destination:=Range("b3:b" & Range("f" & Rows.Count).End(xlUp).Row)
Range("c3").FormulaLocal = "=SI(H3=0|0|SI(I3-I2=1|""OK""|""FA""))"
Range("c3").AutoFill Destination:=Range("c3:c" & Range("f" & Rows.Count).End(xlUp).Row)

Lo que quiero es simplificar la rutina, o sea de una sola vez seleccionar las tres celdas y copiarlas hasta el final de la columna con datos F

Saludos cordiales

Jesús

Etiquetas: 

pacomegia
Imagen de pacomegia
Online
última acción: Hace 14 mins 32 segs
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10900
si no te entiendo mal, en vez

si no te entiendo mal, en vez de escribir una fórmula y extender sólo esa fórmula (y esto tres veces), lo que querrías es

  • escribir la fórmula 1
  • escribir la fórmula 2
  • escribir la fórmula 3
  • Extender las tres a la vez

Pues bien. el truco está en indicar el rango sobre el que quieres hacer el AutoFill

    Range("a3").FormulaLocal = "=SUBTOTALES(103;$F$3:F3)"

    Range("b3").FormulaLocal = "=SI(ColorFondoIgual(E3;204;255;255);""X"";)"

    Range("c3").FormulaLocal = "=SI(H3=0;0;SI(I3-I2=1;""OK"";""FA""))"

    Range("a3:c3").AutoFill Destination:=Range("a3:c" & Range("f" & Rows.Count).End(xlUp).Row)

 

 

 

 

------
Ya sé Excel, pero necesito más.

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 11 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Gracias

Muchas gracias

saludos cordiales

Jesús

TEMA SOLUCIONADO

Jesus Martinez Plantarosa