REFERENCIA A PESTAÑAS

7 envíos / 0 nuevos
Último envío
Mjeronimo
Imagen de Mjeronimo
Offline
última acción: Hace 5 años 4 semanas
alta: 09/06/2015 - 14:49
Puntos: 180
REFERENCIA A PESTAÑAS

Buenas tardes,

tengo la necesidad de hacer un excel donde dispongo de una hoja resumen. Esta hoja resumen busca datos el las otras hojas para recopilar información ordenada, pero he de seguir creando hojas nuevas.

Mi consulta es si alguien sabe si se puede buscar información en pestañas nuevas haciendo referencia a una celda:

 

LO IDEAL SERÍA CAMBIAR LA SEGUNDA FORMULA POR LA PRIMERA, PERO DA ERROR:

                    A                             B                            C                       D

 1          Nombre Pestaña    Fórmula de busqueda 

 2                   U1                =BUSCARV($P$3;'U1'!$C$9:$k$13;2;falso)

                                          =BUSCARV($P$3;'A2'!$C$9:$k$13;2;falso)

 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 3 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10900
INDIRECTO

Para poner una referencia "cambiante" puedes utilizar la función INDIRECTO

construyes una cadena de texto y la interpreta como una referencia a una celda.

Tiene algunos inconvenientes, como el hecho de ser volátil (siempre se está recalculando) y que al ser un texto, no se actualizan las referencias si por ejemplo insertas una fila o una columna, a fin de cuentas es un texto, pero parece que para tu caso es justo lo que necesitas.

 

------
Ya sé Excel, pero necesito más.

Mjeronimo
Imagen de Mjeronimo
Offline
última acción: Hace 5 años 4 semanas
alta: 09/06/2015 - 14:49
Puntos: 180
PESTAÑAS

Buenas PAco,

 

gracias por tu aportación, pero con la fórmula INDIRECTO no puedo hacer referencia a Pestañas.

he intentado con:

=BUSCARV(P3;'"U"&A4'!$C$9:$K$13;2;FALSO), siendo el contenido de A4 el número 1. para que me referencie a la pestaña U1, pero no hay manera.

 

 

Sigo provando

 

Saludos,

 

 

er2015

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 3 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10900
sí se puede

Sí se puede hacer referencia a pestañas, compruebalo

Ten en cuenta que la referencia a otra hoja sólo debe llevar comilla simple si el nombre de la hoja tiene espacios, Si el nombre no tiene espacios, entonces no hay que poner las comillas simples y si las pones no funcionará

=Hoja1!A1

='Hoja con espacios'!A1

 

------
Ya sé Excel, pero necesito más.

Mjeronimo
Imagen de Mjeronimo
Offline
última acción: Hace 5 años 4 semanas
alta: 09/06/2015 - 14:49
Puntos: 180
si esto lo conozco, pero

si esto lo conozco, pero cuando intento que me referencie automáticamente la pestaña no lo detecta:

=BUSCARV($P4;'U1'!$C$9:$K$13;2;FALSO)

La Pestaña se llama U1 (de esta forma funciona)

 

Pero si quiero que me referencie la pestaña con la información de una celda no lo detecta:

 

=BUSCARV($P4;"U"&A4!$C$9:$K$13;2;FALSO)

Nombre de pestaña: U1

Contenido en celda A4: 1

 

Saludos,

er2015

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 3 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10900
¿pero por qué no utilizas la

¿pero por qué no utilizas la función INDIRECTO como te estoy sugiriendo?

=BUSCARV($P4;INDIRECTO("U"&A4 & "!$C$9:$K$13");2;FALSO)

 

------
Ya sé Excel, pero necesito más.

Mjeronimo
Imagen de Mjeronimo
Offline
última acción: Hace 5 años 4 semanas
alta: 09/06/2015 - 14:49
Puntos: 180
GRACIAS, estaba empleandolo

GRACIAS, estaba empleandolo mal.

 

 

er2015