par o impar

4 envíos / 0 nuevos
Último envío
juandudas
Imagen de juandudas
Offline
última acción: Hace 3 años 10 meses
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 27/12/2006 - 23:36
Puntos: 2578
par o impar

Hola de nuevo.

Alguien Sabe si hay alguna función para saber si un número es par o impar, o alguna manera de identificarlo para poder juntar todos los pares por un lado y los impares por otro???

gracias

acampelo
Imagen de acampelo
Offline
última acción: Hace 11 años 6 meses
alta: 08/05/2009 - 20:41
Puntos: 105
Re: par o impar

 

No se si te servirá esta solución.
Utiliza una función SI en la que si dividimos el número por dos y  si su residuo es igual a cero el número es par y por lo tanto que lo ponga. En caso contrario que deje la celda en blanco.
Para los impares el residuo tendrá que ser distinto a O.
 
=SI(RESIDUO(B2;2)=0;B2;"")
 
=SI(RESIDUO(B2;2)<>0;B2;"")
AdjuntoTamaño
Office spreadsheet icon residuo.xls13.5 KB
aquijano
Imagen de aquijano
Offline
última acción: Hace 8 años 3 meses
Nivel 1 - 200 puntosNivel 2 - 500 puntos
alta: 20/07/2008 - 13:32
Puntos: 955
es.par

En Excel 2007 está la función ES.PAR y ES.IMPAR que devuelve verdadero o falso según el caso.

No sé si está en versiones anteriores.

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 14 horas 35 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Re: es.par

En versiones anteriores también está disponible, no sé si directamente o dentro del complemento de herramientas para análisis

------
Ya sé Excel, pero necesito más
La potencia sin control no sirve de nada.

 

------
Ya sé Excel, pero necesito más.