FUNCION SI JUNTO con Y y con O

3 envíos / 0 nuevos
Último envío
ALICIARG
Imagen de ALICIARG
Offline
última acción: Hace 2 años 5 meses
alta: 25/08/2016 - 12:13
Puntos: 555
FUNCION SI JUNTO con Y y con O

Hola:

¿Como puedo juntar estas dos fórmulas?::

      A

2   Finalizacion vida ==> IMPAGO

3   Baja por impago ==> IMPAGO

4   PENDIENTE DEFINIR==> BAJA VOLUNTARIA

5   PORTABILIDAD ==> PORTABILIDAD


=SI(O(A2="Finalizacion vida";A2="Baja por impago");"IMPAGO";A2)

=SI(A2="PENDIENTE DEFINIR";"BAJA VOLUNTARIA";A2)

Mil gracias¡¡

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 2 horas 47 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 11005
yo pondría la segunda fórmula

yo pondría la segunda fórmula dentro de la primera, en el argumento que corresponde al caso de que no se cumpla la primera condición. si se cumple la condición -> impago; si no se cumple -> la segunda fórmula

=SI(O(A2="Finalizacion vida";A2="Baja por impago");"IMPAGO";SI(A2="PENDIENTE DEFINIR";"BAJA VOLUNTARIA";A2))

 

otra idea: En este caso concreto en que lo que haces es elegir un resultado de una lista, según el dato inicial, yo crearía una tabla con tus parejas, y utilizaría la función BUSCARV para encontrar el resultado que me interesa de esa tabla. Esta solución con BUSCARV simplificaría mucho en el futuro si se añade un nuevo caso, porque no tendrías qeu modificar tu fórmula de búsqueda.

 

------
Ya sé Excel, pero necesito más.

ALICIARG
Imagen de ALICIARG
Offline
última acción: Hace 2 años 5 meses
alta: 25/08/2016 - 12:13
Puntos: 555
Buena idea!! Gracias 

Buena idea!! Gracias