farmula en macro

2 envíos / 0 nuevos
Último envío
tetorin
Imagen de tetorin
Offline
última acción: Hace 1 mes 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 26/05/2011 - 02:57
Puntos: 3202
farmula en macro

tengo un listado con datos en la columna A,lo cual extraigo solo una palabra y tengo esta formula y si me funciona bien  pero quisiera usar una macro ya que son muchas las diferentes palabras de extraer y me gustaria poner el listado en una hoja de excel y que de ahi las tomara

 

esta es mi formula


=SI(ESERROR(HALLAR("fertil",A2)),
SI(ESERROR(HALLAR("embarazadas",A2)),
SI(ESERROR(HALLAR("r1",A2)),
SI(ESERROR(HALLAR("suplementaciones",A2)),
SI(ESERROR(HALLAR("vunas",A2)),
"NO EXISTE","vacunas"),"suplementaciones"),"r1"),"embarazadas"),"fertil")

 


 

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 1 hora 28 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10750
InStr

En VBA tienes la función InStr para averiguar si un texto está dentro de otro.

por ejemplo

InStr("tomate","mate")

da como resultado 3 (encuentra "mate" en la posición 3 de la cadena "tomate")

si no lo encuentra devuelve 0

así que se trataría de ir probando cada texto mediante esta función, por ejemplo mediante muchos If... then 

 

 

------
Ya sé Excel, pero necesito más.