¿Existe alguna forma de indicar mas columnas en excel con indice?

3 envíos / 0 nuevos
Último envío
Jose Francisco ...
Imagen de Jose Francisco Martínez Martínez
Offline
última acción: Hace 5 meses 2 semanas
alta: 19/02/2020 - 17:41
Puntos: 95
¿Existe alguna forma de indicar mas columnas en excel con indice?

Hola, este es mi segundo post en esta página.

El planteamiento viene dado debido a que tengo que realizar una primitiva en excel. No es para adivinar ninguna predicción, para ganarla, por que ni la hecho ni me interesa. El caso, es que, es un ejercicio donde tengo seis "bombos" de los cuales necesito sacar un numero de los que hay. Estan entre 1 y 49. la formula para sacarlos es

=INDICE(B3:D20;ALEATORIO.ENTRE(1;CONTARA(B3:D20));2) 

Solo puedo acceder a una columna por lo cual, el resto de las columnas del bombo (C,D) no pueden ser usadas. Quizás me estoy equivocando en el planteamiento. Es para sacar un número aleatorio en excel. 

AdjuntoTamaño
Image icon prueba1.png97.08 KB

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 2 días 6 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
No, eso no se puede hacer.Sin

No, eso no se puede hacer.

Sin embargo, puedes poner los 49 números en una sola columna.

Otra cosa que se me ocurre es utilizar dos aleatorios (uno para fila y otro para columna), aunque tendrías que ajustar las probabilidades para las columnas para que sean similares en todos los números.

Por otro lado, si los bombos tienen todos los números del 1 al 49, no necesitas ponerlos en ningún sitio. Saca un ALEATORIO.ENTRE(1;49) y ya está. Luego, si quieres marcarlo en tu "bombo", utiliza un formato condicional ahí para que se coloree el que se haya seleccionado en la fórmula.

Un fallo que le veo es que te pueden salir números repetidos. Eso habría que solucionarlo de alguna manera.

 

Un saludo

Jose Francisco ...
Imagen de Jose Francisco Martínez Martínez
Offline
última acción: Hace 5 meses 2 semanas
alta: 19/02/2020 - 17:41
Puntos: 95
Hola, me gustaría comentarte

Hola, me gustaría comentarte lo siguiente.

La fórmula de los bombos es =ENTERO(ALEATORIO()*49+1) y la sustituí por esa misma. Pero, para sacar el numero aleatorio de un rango de celdas, no se como indicarlo, cuando hay varias columnas, como tu has dicho con aleatorio aunque no me ha quedado claro debido al problema de varias columnas

Sobre lo de repetir,pues estuve buscando por internet y estoy, tratando de arregrarlo con jerarquía