Copiar valores y formula

10 envíos / 0 nuevos
Último envío
Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Copiar valores y formula

Buenas Tardes

Adjunto mi libro de trabajo con dos hojas de calculo, una SOL y otra SOLEMI, lo que hace mi macro es copiar el contenido de SOL desde A1 a S100 a SOLEMI, copia ese rango que según yo es lo que entraria el total de los datos a copiar de la hoja, esta hoja en la  parte de totales es movible, de acuerdo a la cantidad de datos a copiar que amerite, es por eso que tome ese rango, en la parte de totales lo de amarillo de SOL, y al copiar a SOLEMI obviamente lo que esta en la columna T de SOL No lo copia porque hay formulas que no necesito copiar a SOLEMI, es por eso que cuando copio a SOLEMI pego solo como valores, como puedo copiar la formula de los totales de la hoja SOL cuando copia a SOLEMI ?

Desde ya muchas gracias.

Saludos cordiales


Jesús 

AdjuntoTamaño
File copiarform.xlsm65.82 KB

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 14 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
UtilizaSelection.PasteSpecial

Utiliza

Selection.PasteSpecial Paste:=xlPasteFormulas

En vez de 

Selection.PasteSpecial Paste:=xlValues

Un saludo

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Gracias

Sii muchas gracias gracias

saludos cordiales

Jesús

TEMA SOLUCIONADO

Jesus Martinez Plantarosa

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Ayuda

 

Estimado Cron:

Disculpa que vuelva a escribir en este tema que lo puse como solucionado, pasa que hice las pruebas como corresponde pero no me fije un detalle, en la columana P tengo la siguiente formula 

 =SI(N8=0|0|+N8*T8) 

 y bueno al copiar como formula con la corrección que me hiciste, el valor de estas celdas copia con valor cero, pero necesito que copie los montos que estan en estas celdas, espero me comprendas y gracias por la paciencia.

saludos cordiales

Jesús

Jesus Martinez Plantarosa

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 14 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Entiendo que no se copia con

Entiendo que no se copia con valor 0. Probablemente lo que ocurre es que copiado la columna P, pero no las columnas N y T, por lo que al calcular la fórmula el resultado es 0.

¿Van por ahí los tiros? 

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Solución

Estimado Cron cual seria la solución???

Jesus Martinez Plantarosa

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 14 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Podría ser copiar también las

Podría ser copiar también las columnas N y T.

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Formulas

lo que pasa que al copiar la columna T hace referencia la formula 

=INDICE($V$1:$Z$2|COINCIDIR($C$4|$U$1:$U$2|0)|COINCIDIR($C8|$V$1:$Z$1|0))

y al copiar a la otra hoja con la macro inserta filas para ir introduciendo nuevas notas y por ende no da la formulas, porque se desconfigura.

Ayuda por favor

Jesús 

 

Jesus Martinez Plantarosa

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 14 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Prueba a quitar los $ que no

Prueba a quitar los $ que no sean imprescindibles. Si vas a insertar columnas, quita los $ de delante de las letras, y si vas a insertar filas, quita los de delante de los números.

Ojalá te sirva.

Jesús Martínez
Imagen de Jesús Martínez
Offline
última acción: Hace 3 meses 3 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 5008
Buena idea

Siii gracias por iluminarme, un abrazo

Jesús

AHORA SI TEMA SOLUCIONADO :)

Jesus Martinez Plantarosa