Contar.si

3 envíos / 0 nuevos
Último envío
mariam
Imagen de mariam
Offline
última acción: Hace 10 años 2 meses
alta: 09/01/2009 - 13:16
Puntos: 70
Contar.si

Hola. En una hoja excel tengo una columna en la que aparecen distintas fechas. Necesito saber el nº de fechas que son sábado.

En principio había pensado usar la función CONTAR.SI, pero no sé como expresar que el criterio sea "sábado".

También había pensado usar alguna de las funciones que describes en tu libro en el apartado "funciones de fecha", pero como la versión excel que tengo en el trabajo es la 2003, no sé cómo se carga el complemento "Herramientas de Análisis" para tener la función DIAS.LAB.

Muchas gracias

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 8 horas 46 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10590
Re: Contar.si

Para cargar el complemento Herramientas para Análisis ve a

Herramientas>Complementos

luego activa este complemento y pulsa Aceptar

 

Para saber qué día de la semana es una fecha, utiliza la función DIASEM, que devuelve un número del 1 al 7 según el día de la semana que se trate.

El segundo argumento de la función indica si quieres que el 1 sea el Domingo (supongo que para los anglosajones) o prefieres que el lunes sea el 1 (esto es a lo que estamos acostumbrados, al menos en España), en este último caso pon un 2 en el segundo argumento

=DIASEM(tufecha;2)

 

Data Tools Suite
datos y tablas con Excel

rulesagain
Imagen de rulesagain
Offline
última acción: Hace 5 años 6 meses
Nivel 1 - 200 puntos
alta: 22/10/2011 - 23:50
Puntos: 210
Re: Contar.si

Wil

Para saber el dia que corresponde a tu fecha utiliza la siguiente funcion de ejemplo:

A1 b1

1 05/11/2011 =TEXTO(A1;"dddd") te da el dia Sábado

2

3

Ahora si puedes utilizar la funcion contar,si

=CONTAR.SI(B1;"Sábado") te da como resultado 1

Espero te sirva todavia

Saludos Todo bien

Wil