Problema con MACRO "=BUSCARV"

8 envíos / 0 nuevos
Último envío
morpheus55vic@g...
Imagen de morpheus55vic@gmail.com
Offline
última acción: Hace 9 años 6 meses
alta: 07/05/2011 - 11:29
Puntos: 55
Problema con MACRO "=BUSCARV"

Buenas a todos son nuevo en el foro, y tengo una dudilla a ver si algun alma caritativa me echa una mano.

Tengo una lista de peliculas y quiero añadir un macro para poder buscar. Esto es lo que tengo hasta ahora:

 

=BUSCARV(N4;Titulo;Tipo_pelicula;FALSO)

 

 

Ponga el valor que pongo me sale #¡VALOR!, incluso como podeis ver asigne un nombre de rango a la columna B y C.

 

Ayuda!!! a ver si logro sacar esto.

Gracias!

 

 

 

 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 18 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Ojo con los argumentos.

El segundo argumento de la función NO es sólo la columna con los títulos, sino que tiene que ser la matriz completa, los títulos y los tipos. en tu caso será el rango $B3:$C*

El tercer argumento no es el rango del resultado, sino un número, el número de columna donde está el resultado, en tu caso un 2.

------
Ya sé Excel, pero necesito más ahora en pdf

 

------
Ya sé Excel, pero necesito más.

morpheus55vic@g...
Imagen de morpheus55vic@gmail.com
Offline
última acción: Hace 9 años 6 meses
alta: 07/05/2011 - 11:29
Puntos: 55
Re: Ojo con los argumentos.

Hola! gracias por contestar tan rapido.

Si pongo esto me da error, tengo algo mal?? Muchas gracias!!

=BUSCARV(K4;$B3:$C*;Tipo_pelicula;FALSO)

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 18 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Re: Ojo con los argumentos.

puse un asterisco porque no sé hasta donde llegan tus datos. prueba con esto:

=BUSCARV(N4;$B$3:$C$100;2;FALSO)

¿era K4 o N4?

------
Ya sé Excel, pero necesito más ahora en pdf

 

------
Ya sé Excel, pero necesito más.

morpheus55vic@g...
Imagen de morpheus55vic@gmail.com
Offline
última acción: Hace 9 años 6 meses
alta: 07/05/2011 - 11:29
Puntos: 55
Re: Ojo con los argumentos.

Ya funciona!!! muchisimas gracias!!!! puedo meter este buscador en otra hoja excel? para tener en una la lista y en otra el buscador

 

Gracias!

 

EDITO: he probado a meterlo en otra hoja y da error, donde tengo que indicarle en donde esta la hoja de la lista??

morpheus55vic@g...
Imagen de morpheus55vic@gmail.com
Offline
última acción: Hace 9 años 6 meses
alta: 07/05/2011 - 11:29
Puntos: 55
Re: Ojo con los argumentos.

Ya está solucionado. lo tengo en dos hojas distintas. Muchas gracias por todo, no podia imaginar el poder que tenia excel hasta hoy.

 

un saludo!

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 18 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
esto no es nada

pues esto no es nada para lo que es capaz de hacer.

------
Ya sé Excel, pero necesito más ahora en pdf

 

------
Ya sé Excel, pero necesito más.

Cron
Imagen de Cron
Offline
última acción: Hace 1 mes 1 semana
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12715
Re: Ojo con los argumentos.
Es cierto que BuscarV es una función a la que se le pueden dar muchísimas utilidades siempre que se diseñe la hoja pensando en su funcionamiento. Conocí a alguien que decía que el Excel es el mejor invento de la humanidad después de la rueda. Saludos