BuscarV en varios libros

6 envíos / 0 nuevos
Último envío
cesar
Imagen de cesar
Offline
última acción: Hace 6 años 2 meses
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntos
alta: 23/02/2013 - 15:12
Puntos: 1258
BuscarV en varios libros

Habra alguna manera de usar la funcion BuscarV con referencia a otros libros? 

Digamos que quiero hacer la busqueda de un valor X y necesito buscar este valor en otros libros de Excel (aclaro que no me refiero a otras Hojas del mismo libro sino a otro documento de Excel. Es esto posible?

Gracias -

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 1 día 8 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10690
Re: BuscarV en varios libros

Casi cualquier función de Excel puede hacer referencia a una celda de otro libro. Digo casi porque con algunas no funciona si no tienes abiertos los dos libros.

Abre los dos libros, y en una celda de un libro escribe la fórmula: Elige con el ratón el rango en el otro libro, verás cómo se muestra la fórmula

Será algo con este aspecto 

=BUSCARV(A2;[Libro2.xlsx]Hoja1!$A$1:$D$8;2;FALSO)

Aparece el nombre del otro libro ente cochetes. Cuando cierres el segundo libro, la fórmula mostrará entre comillas simples la ruta hasta el archivo

=BUSCARV(A2;'C:\Users\tunombredeusuario\Documents\loquesea\[Libro2.xlsx]Hoja1'!$A$1:$D$8;2;FALSO)

 

Cada vez que abras el Libro donde está este vínculo externo, Excel te preguntará si quieres actualizar los vínculos o no (para que abra internamente los otros libros y vea el valor al que te refieres.

actualizar vínculos externos excel

 

------
Ya sé Excel, pero necesito más.

cesar
Imagen de cesar
Offline
última acción: Hace 6 años 2 meses
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntos
alta: 23/02/2013 - 15:12
Puntos: 1258
Re: BuscarV en varios libros

Muchisimas gracias por esta informacion tan valiosa Pacco!! Agradezco mucho que te tomes el tiempo en ayudarnos a eliminar cualquier duda posible.

 

De hecho habia tratado de hacerlo pero no me daba lo que queria..al parecer el problema era con los monitores..tengo una computadora linked a dos monitores y entonces lo que hacia era abrir 2 libros diferentes en un monitor y colocar el otro en el otro monitor pero al hacer esto la formula no se copiaba del todo. 

 

Lo que hice fue colocar ambos libros en el mismo monitor y pues ahi si me funciono..extrano!!! :) 

 

Muchisimas gracias por todo

leninpuga
Imagen de leninpuga
Offline
última acción: Hace 6 años 9 meses
alta: 14/02/2014 - 22:22
Puntos: 15
Re: BuscarV en varios libros

Hola Cesar, en esta ocasión comparto contigo y el foro como hacer una busqueda cuando tienes dos opciones de respuesta, en mi caso es usando la función SI y la función de BUSCARV o CONSULTA (depende el SP).

Este es el caso:

Tienes tres libros y en uno tienes el reporte el cual debe buscar el resultado del inventario dependiendo del modelo (son dos modelos) y sucede que los inventarios están cada uno en un libro aparte.

 

Te anexo los archivos para que veas como se resuelve. Saludos.

AdjuntoTamaño
File resultado.xlsx10.73 KB
File marinos.xlsx7.96 KB
File terrestres.xlsx7.95 KB

Capacitación en Excel en www.capacitateexcel.com

visitante (no verificado)
Imagen de visitante
Que sucede con mi excel?.

Que sucede con mi excel?. Hago como dices y la formula nunca se muestra. Solo si la hago en el mismo libro..Algo no está configurado bien?.. Muchas gracias por su atencion.!

 

 

Esteban David (no verificado)
Imagen de visitante
buscarv

ok muy  bien,pero una duda si este archivo se encuetra  en otro lado pero me muestra un mensaje de recalculando y se pone lenta ,,como hacer para que no pase o no se alente a los demas usuarios ya que ese archivo solo es captura y relaciono toda esa informacion al mio y hago tambien que se capture solo a ese mismo para no estar abriendo ese archivo ya no mas abro el mio, capturo y ya esta capturado en el otro. espero tu respuesta gracias 

Saludos