Buscar, Devolver y Sumar

5 envíos / 0 nuevos
Último envío
kazuo09
Imagen de kazuo09
Offline
última acción: Hace 8 años 2 semanas
alta: 20/03/2012 - 15:18
Puntos: 25
Buscar, Devolver y Sumar

Hola a todos!!!

Mi duda es la siguiente:

Necesito buscar un dato en una columna y si existe que me devuelva su valor correspondiente, pero la cuestión es que dentro de esta columna el dato se repite más de una vez (en ocasiones hasta 20 veces). He usado la función "BUSCARV" pero ésta sólo me devuelve el valor del primer dato que se encuentra en la columna, y lo que yo quiero es que si existen 5 datos el resultado que me arroje sea la suma de estos:

Ejemplo tengo una columna llamada "Nombre", en ella se enlistan 10 nombres de personas; dentro de ellas está Juan, nombre que se repite 3 veces. La segunda columna se refiere a "ahorros" y los valores correspondientes a los tres Juan son: 100, 200 y 50. Cuándo yo aplico la función "BUSCARV" me devuelve el valor de 100 (que es el primero que aparece), pero lo que yo quiero es que si hay 3 Juan, me sume 100 + 200 + 50 = 350.

Existe alguna función que me facilitará la tarea de tener que hacer formulas muy grandes para poder llegar al resultado deseado ????

Espero puedan ayudarme, de antemano gracias!!!

 

universoexcel
Imagen de universoexcel
Offline
última acción: Hace 2 años 8 meses
Nivel 1 - 200 puntosNivel 2 - 500 puntos
alta: 25/10/2011 - 19:41
Puntos: 710
Re: Buscar, Devolver y Sumar

La función que estás buscando es la de SUMAR.SI, esta función suma todos los valores iguales en un rango.

En tu caso, suponiendo que los nombres están en la columna "A" del renglon 2 al 10, y que los ahorros están en la columna "B2:B10"

la fórmula quedaría así= SUMAR.SI("Juan",$A$2:$A$10,$B$2:$B$10)

y te daría la suma de todos aquellos clientes llamados juan, en la columna "A", cuyos ahorros se encuentran en la columna "B"

Visitanos en http://universoexcel.com

visitante (no verificado)
Imagen de visitante
Re: Buscar, Devolver y Sumar

Fenomenal!!!

Gracias Amigo (a)!!! me fue de mucha ayuda....excelente foro, la respuesta fue rápida y efectiva.

Que tengas un excelente día :D

visitante (no verificado)
Imagen de visitante
Re: Buscar, Devolver y Sumar

Muy buenas tardes. No conozco una función que haga esto, si la hay.

Pero con Tablas Dinámicas se puede lograr una solución.

He preparado un ejemplo que con gusto se lo envío si me envía su email a japorras1@une.net.co

Cordialmente,

Jorge A. Porras

visitante (no verificado)
Imagen de visitante
Re: Buscar, Devolver y Sumar

Buena tarde Jorge!!!

Gracias por atender a mi duda.

    Mi correo es: kazuo_akari@hotmail.com

 

Espero pueda hacerme llegar el ejemplo que elaboró con tablas dinámicas para poderlo analizar. De antemano gracias.

Que tenga una excelente tarde!!!