Buscar el costo mínimo en una tabla e indicar el nombre del encabezado más bajo.

5 envíos / 0 nuevos
Último envío
Chicho
Imagen de Chicho
Offline
última acción: Hace 7 años 7 meses
alta: 05/05/2012 - 18:30
Puntos: 25
Buscar el costo mínimo en una tabla e indicar el nombre del encabezado más bajo.

Saludos a todos, esta es la primera vez que participo, espero darme a entender.

 

Generalmente debo analizar listas de precios y seleccionar aquellos que sean los más baratos de diversos proveedores, para ello armo tablas en las que las primeras columnas son datos generales como cantidad, unidad de medida, descripción de artículos; en las siguientes columnas coloco el costo que me da cada proveedor identificado en el encabezado de la columna el nombre del mismo. 

Lo que busco es una opción que me ayude a seleccionar el precio más barato (con la función =min()), pero además indique el nombre del proveedor que fué más barato.

 

Ya lo he resuelto pero la fórmula queda muy larga y tiene límite.

=SI(O18=G18,P18,SI(Q18=G18,R18,SI(S18=G18,T18,SI(U18=G18,V18,SI(W18=G18,X18,SI(Y18=G18,Z18,""))))))

 

En esta fórmula G18 lo obtengo con la función min(), con lo que ya se cual es el número mas chico, lo que hace la fórmula grande es buscar una por una las columnas y cuando encuentra el valor que conincide, jala el valor contiguo (el nombre del proveedor)

 

Supongo que una fórmula del tipo =BUSCARV(C3,Listas!G3:I21,2,FALSO) me podría ayudar, pero solo la se aplicar en búsquedas sobre columnas en las que la búsqueda es vertical y el valor buscado está sobre la misma fila del que se va recuperar.

 

En mi caso, la búsqueda debe ser horizontal y el valor a arrojar estará sobre la columna del valor encontrado.

 

Les agradeceré mucho su apoyo.

 

Va un ejemplo.

ProductoCantidadProveedor 1Proveedor 2Proveedor 3Precio más bajoMás económico
Producto 145 $       64.00 $       60.00 $       70.00 $       60.00Proveedor 2
Producto 265 $       34.00 $       35.00 $       37.00 $       34.00Proveedor 1
Producto 3100 $       87.00 $       76.00 $       90.00 $       76.00Proveedor 2
Producto 410 $       13.50 $       11.00 $       12.00 $       11.00Proveedor 2
Producto 55 $     100.00 $       99.00 $       89.00 $       89.00Proveedor 3
pacomegia
Imagen de pacomegia
Offline
última acción: Hace 2 días 1 hora
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10560
COINCIDIR e INDICE

para encontrar la posición puedes emplear la función COINCIDIR

en tu caso, si empleas una fórmula como esta:

=COINCIDIR(G18;D18:F18;0)

obtendrás la posición en la que coincide el valor G18 de tu mínimo dentro de D18:F18, en tu caso sería la posición 2 (entiendo que en la fila 18 está el producto 1 y el mínimo es 60, que está en la posición 2)

Luego puedes utilizar ese valor como argumento de la función INDICE para que te devuelva el proveedor

por ejemplo:

=INDICE($D$17:$F$17;1;COINCIDIR(G18;D18:F18;0))

aquí he supuesto que los nombres de los proveedores están en $D$17:$F$17 (he puesto referencia absoluta con $ para que se pueda extender la fórmula hacia abajo), el segundo argumento indica el número de fila que en este caso es la 1, porque sólo tenemos una fila, y el tercer argumento es el número de columna, que es donde ponemos la función COINCIDIR.

 

Data Tools Suite
datos y tablas con Excel

Claudio Alaniz (no verificado)
Imagen de Claudio Alaniz
muchas gracias

Estimado "Pacomegia" muchas gracias por tu amorte mer sirvio de mucho, saludos.-

Euncie (no verificado)
Imagen de Claudio Alaniz
costo minimo en una tabla y mostrar encabezado

[comentario movido a tema nuevo en el foro http://www.necesitomas.com/costo-minimo-tabla-y-mostrar-encabezado]

 

Pavlvs (no verificado)
Imagen de Claudio Alaniz
Muchas gracias!

Gracias! Te pasaste! Me ha sido de mucha ayuda, saludos y bendiciones