Tablas y versiones de Excel

8 envíos / 0 nuevos
Último envío
Cron
Imagen de Cron
Offline
última acción: Hace 13 horas 9 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8860
Tablas y versiones de Excel

Hola

 

Como ya he comentado en otras preguntas, estoy trabajando en una hoja que utiliza tablas para introducir la información. La creación, adición de columnas y filas, recálculos, etc se hace mediante código.

 

El caso es que utilizo la última columna para totalizar los datos de cada fila, por lo que pongo una fórmula de esta guisa:

=SUMA(TablaDIC11[[#Esta fila];[Anterior]:[25-dic]])

 

Cuando se lo paso a la persona que tiene que trabajar con la tabla, en otro ordenador, su fórmula es de esta guisa:

 

=SUMA(D2:N2)

 

La mayoría de las ocasiones me está funcionando bien, pero en algunos casos me da errores u obvia cálculos (sencillamente no hace nada cuando tiene que calcular la celda en cuestión)

En realidad, el fallo no me lo da cuando introduzco la fórmula en la celda, sino cuando calculo mediante código utilizando el estilo de fórmulas relacionadas con las tablas. Pero solo me lo da en el ordenador otro. En el mío funciona todo correctamente y no puedo reproducir el fallo.

¿Es posible que los fallos tengan que ver con la diferencia de versión? ¿Estoy haciendo algo mal? ¿No es posible y tengo que buscar el fallo por otro lado?

 

Gracias y saludos

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 11 horas 2 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 7590
Re: Tablas y versiones de Excel

tendrías un problema de versiones si en el otro equipo no reconociese la fórmula, pero sí la reconoce, así que es un tema de configuración.

Mira cómo está configurada la opción "Usar nombres de tabla en las fórmulas"

configuración de utilización o no nombres de tabla en las fórmulas de Excel

 

------
Ya sé Excel, pero necesito más ahora en pdf

 

Data Tools Suite
datos y tablas con Excel

Cron
Imagen de Cron
Offline
última acción: Hace 13 horas 9 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8860
Re: Tablas y versiones de Excel

Muchas gracias. Lo miraré a ver si esto me soluciona el problema.

 

Saludos

Cron
Imagen de Cron
Offline
última acción: Hace 13 horas 9 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8860
Re: Tablas y versiones de Excel

Eso no era :-(

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 11 horas 2 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 7590
Re: Tablas y versiones de Excel

al cambiar la configuración no se cambian las fórmulas que ya estén introducidas en el libro. esto afecta al momento en que se introduce una nueva fórmula.

¿has probado a introducir una fórmula a mano antes y después de cambiar esta modificación? es para descartar cosas.

-si esto definitivamente no es, ¿qué versión de Excel hay en el equipo donde las fórmulas de tablas aparecen como rangos?¿funcionan esas fórmulas?

------
Ya sé Excel, pero necesito más ahora en pdf

 

Data Tools Suite
datos y tablas con Excel

Cron
Imagen de Cron
Offline
última acción: Hace 13 horas 9 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8860
Re: Tablas y versiones de Excel

No, el problema es que el ordenador donde estoy haciendo las pruebas admite la formulación que comento. El ordenador donde tiene que funcionar la macro parece que no admite según qué cosas (por ejemplo, para seleccionar toda la fila de encabezados con [#Headers])

 

Y la configuración donde comentaste está igual en ambos ordenadores, así que el problema tiene que estar en otro lado.

 

Saludos

Cron
Imagen de Cron
Offline
última acción: Hace 13 horas 9 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8860
Re: Tablas y versiones de Excel

Sí he probado a introducir a mano, y da error en el ordenador "objetivo"

¿Cómo puedo saber exactamente la versión de Excel que está instalada? En ambos casos es la 2007, pero no sé qué "sub-versión" es.

 

Gracias por la ayuda

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 11 horas 2 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 7590
Re: Tablas y versiones de Excel

esto es digno del foro de fenómenos paranormales (de hecho voy a cambiar este tema a ese foro).

la versión la puedes ver en
Opciones de Excel>Recursos>Acerca de...

pero no creo que la diferencia esté aquí.

en la versión 2010 sí han rehecho un poco la nomenclatura para las fórmulas que se refieren a tablas, pero si dices que en ambos equipos hay 2007...

qué raro.

voy a investigar un poco, pero no te prometo nada.

------
Ya sé Excel, pero necesito más ahora en pdf

 

Data Tools Suite
datos y tablas con Excel