Sumar rango variable

3 envíos / 0 nuevos
Último envío
Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 días 12 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4708
Sumar rango variable

Buenas noches:

 

Tengo el siguiente código

Range("L8").End(xlDown).Offset(1, 0).Select

        Selection.FormulaLocal = "=SUMA(L8:L18)"

En el libro que adjunto están los datos llenados hasta la fila 18 , solo que la última fila puede ser de menos o más datos, todo depende del movimiento de las fechas de ventas, POR FAVOR necesito una macro que introduzca la fórmula que sume hasta la última fila con monto, digamos que por ejemplo si el rango aumenta de l8 a l20 , sume ese rango, o si disminuye de l8 a l7 sume ese rango.

 

Muchas gracias por su tiempo.

Saludos cordiales 

Jesús

 

   

AdjuntoTamaño
File suma.xlsx31.3 KB

Etiquetas: 

TitoPaKa
Imagen de TitoPaKa
Online
última acción: Hace 7 mins 36 segs
alta: 16/03/2017 - 06:33
Puntos: 50
Sumar rango variable


Sub Macro2()
'definimos variable
Dim UltLinea As Long

'busco la última fila con datos que y le sumo 1 para colocar el sumatorio, define correctamente la columna y la primera celda que tiene datos
UltLinea = Range("E3").End(xlDown).Row + 1

'escribo la formula en la celda, fijate que le resto uno aquí a UltLinea para que no provoque una redundáncia
Range("E" & UltLinea).FormulaR1C1 = "=SUM(R[-" & UltLinea - 1 & "]C:R[-1]C)"

end sub

Saludos,

Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 días 12 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4708
Muchas gracias, esta bien

Muchas gracias, esta bien

Jesus Martinez Plantarosa