Sumar numeros como horas ???

8 envíos / 0 nuevos
Último envío
eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 1 semana 3 horas
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 1145
Sumar numeros como horas ???

Hola buenas.

Tengo esta formula que me suma numeros de este formato 10,20 6,40 9,30 ect...  a horas minutos.

{=(SUMA(ENTERO(D3:D33))+SUMA((D3:D33)-ENTERO(D3:D33))*100/60)/24}

Lo que quiero y no consigo es sumar con una condicion tengo esta, pero claro para horas minutos no vale.

=SUMAR.SI(B3:B33;1;D3:D33)

Intente asi pero nada demasiados argumentos me dice.

{=(SUMAR.SI(ENTERO(B3:B33;1;D3:D33))+SUMAR.SI((B3:B33;1;D3:D33)-ENTERO(D3:D33))*100/60)/24}

Salud2...

 

 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 17 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9690
columna auxiliar con horas de verdad

¿por qué no añades una columna auxiliar donde las horas sean horas de verdad? luego la puedes poner con formato de fecha/hora para que se lea cómodamente.

un día en Excel (24 horas) es 1 

las 12:00  sería 0.5 (por ejemplo)

haciéndolo así, puedes operar directamente con estos números. La parte entera de tu resultado serán días, y la parte decimal, horas.

 

Bueno, sobre tu fórmula con muchos argumentos: parece que has cambiado los argumentos de la función SUMAR.SI y los has metido dentro de la función ENTERO

Prueba algo así:

{=(SUMAR.SI(B3:B33;1;(ENTERO(D3:D33)+((D3:D33)-ENTERO(D3:D33))*100/60)/24))}

 

 

 

 

 

 

Data Tools Suite
datos y tablas con Excel

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 1 semana 3 horas
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 1145
respuesta

esta formula me da error ???

{=(SUMAR.SI(B3:B33;1;(ENTERO(D3:D33)+((D3:D33)-ENTERO(D3:D33))*100/60)/24))}

Me da igual otra formula, pero que sume horas minutos con una condicion o criterio.

De todas formas subo libro

hoja

dias individuales desglosados por dias en fila 35 resultado horas

hoja

dias original

filas 43  formulas probando

fila 44 resultados enlazados de la hoja dias individuales ok.

 

Salusd2....

AdjuntoTamaño
File para_foro_suma_horas.xlsx115.74 KB
pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 17 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9690
Prueba con esto:{=SUMA(SI(B2

Prueba con algo como esto:

{=SUMA(SI(B2:B32=1;(ENTERO(D2:D32)+((D2:D32)-ENTERO(D2:D32))*100/60)/24;0))}

Lo que hago es poner un SI dentro de la fórmula matricial que devuelve un 0 cuando no se cumple la condición; Luego lo sumo todo, así que ese cero no afecta al resultado final.

Adjunto archivo con ejemplo de fórmulas 

AdjuntoTamaño
File para_foro_suma_horas_revisado.xlsx117.03 KB

 

Data Tools Suite
datos y tablas con Excel

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 1 semana 3 horas
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 1145
respuesta

Parece ok despues la miro mas despacio.

Gracias.

Salud2....

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 1 semana 3 horas
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 1145
respuesta

Todo perfecto.

Un pequeño detalle que he visto, pero seguro que tiene que haber unos cuantos entre tanta hoja, celdas y libros

Ejemplo 10,60 realmente es 11:00 esta fórmula como trata este dato 10,60 ¿??

Gracias.

Salud2...

 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 4 horas 17 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9690
10.60 = 11:00

la fórmula considera la parte entera y le suma la parte decimal dividida entre 60 y multiplicada por 100

es decir

parte dedimal: 0.60

convertida sería igual a 1, 0.60*100/60=1

que se sumaría a la parte entera 10+1=11

Así que según tu fórmula las 10.60 se interpretarían como 11 horas

 

 

Data Tools Suite
datos y tablas con Excel

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 1 semana 3 horas
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 1145
respuesta

ok

Salud2....