Sumar filas desde precedente hasta x filas mas o menos.

2 envíos / 0 nuevos
Último envío
visitante (no verificado)
Imagen de visitante
Sumar filas desde precedente hasta x filas mas o menos.

Buenos días,

Agradezco de antemano su dedicación desinteresada.

Necesito sumar los valores de las filas anteriores en un número x desde la celda que me encuentro.

Es decir, tengo un rango de valores en la columna A desde A1 hasta A100, y necesito sumar los, por ejemplo, últimos 24 valores. Este dato quiero que sea variable y estará en la casilla B1.

Sé hacer A101=SUMA(A77:A100) y que para que cada fila subsiguiente  que haga lo mismo copiar, siguiente, A102=SUMA(A78:A102)

El problema es como decirle a EXCEL que coja el valor A101 le reste 24 filas (en verdad A101-B1) y que me responda A77 para poder insertar en la fórmula A77.

El objeto es hacer una media futura teniendo en cuenta valores hasta la actualidad y proyectar dicha media teniendo encuenta los valores que van dando como resultado. Todo ello, pudiendo tener en cuenta los últimos 12, 24, 60 meses, etc... según sea necesario.

Un saludo,

Luis del Sol

[tema creado desde comentario en http://www.necesitomas.com/seleccionar-area-utilizando-variable-como-numero-fila#comment-13538]

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 5 días 49 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 11110
Lo que tú estás pidiendo es

Lo que tú estás pidiendo es la función DESREF.

DESREF tiene 5 parámetros. Es como buscar el tesoro en la isla del pirata.

-El primer parámetro te dice dónde empezar a contar.

-Los parámetros 2 y 3 te dicen los pasos que tienes que dar hacia el sur y hacia el este.

-Los parámetros 4 y 5 te dicen lo ancho y largo que tienes que hacer el agujero.

En tu caso, yo pondría como parámetros:

-1: A100 - porque es la celda desde la que queremos empezar a contar.

-2 y 3: 0;0 - porque no quiero desplazarme desde A100

-4 y 5: -B1;1 - Porque quiero que la altura del rango sea la que hay en B1. El signo - es para contar desde A100 hacia arriba. El 1 del 5º parámetro es porque quiero que el rango tenga una columna.

Una vez tenemos el rango de 1 columna de ancho, y el valor de B1 de alto, contando desde A100 hacia arriba, lo que tenemos que hacer es sacar el promedio.

Así que la fórmula quedará más o menos así:

=PROMEDIO(DESREF(A100;0;0;-B1;1))

 

Un saludo