Sumar celdas cada n filas

5 envíos / 0 nuevos
Último envío
pumuky
Imagen de pumuky
Offline
última acción: Hace 1 año 6 meses
alta: 25/05/2016 - 06:41
Puntos: 45
Sumar celdas cada n filas

Hola!

Tengo una hoja excell con valores de radiacion solar horaria durante 3 años, los he agrupado por meses y necesito sumar las horas del mismo mes, es decir para enero me saldrian 24 valores, igual para febrero y asi con todos los meses.

He intentado utilizar la formula (=SUMA(SI(RESIDUO(F2:F745;24)=0,F2:F745))) porque quiero sumar todos los valores que me resultan a la 1 de la mañana de todos los dias del mes de enero (Enero es la columna F)

Esta formula tampoco me funciona... =SUMAPRODUCTO((RESIDUO(FILA(F4:F747);24)=0)*F4:F747)

¿alguna idea? Gracias!

 

 

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 12 horas 4 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8870
Depende de cómo tengas los

Depende de cómo tengas los valores de la hora. Pueden ser valores enteros, valores de hora (y por definición, decimales), textos...

¿Cómo lo tienes guardado? 

pumuky
Imagen de pumuky
Offline
última acción: Hace 1 año 6 meses
alta: 25/05/2016 - 06:41
Puntos: 45
Numeros enteros

La radiacion te da un numero entero, es la columna de radiacion la que quiero sumar para saber por ejemplo , en el mes de enero cual es el promedio de radiacion que sucede a las 14 horas.

Envio el archivo por si aclara un poco mas

AdjuntoTamaño
File radiacion_mensual_horaria.xlsx202.41 KB
Cron
Imagen de Cron
Offline
última acción: Hace 12 horas 4 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8870
Efectivamente, las horas

Efectivamente, las horas están en formato fecha, por lo que son valores decimales. Lo más sencillo es utilizar una columna auxiliar. Yo he probado una columna auxiliar con la fórmula =HORA(A2) Esto te da el valor de la hora en número entero. Luego puedes utilizar la fórmula SUMAR.SI(rango de la columna con la hora;valor de la hora a sumar;rango de la columna a sumar)

En tu caso, yo reordenaría los datos (a menos que quieras presentarlos así). Lo que haría es ponerlos todos en la misma columna y sacar tres columnas auxiliares: hora, mes y año. De esta manera, podrás filtrar los datos utilizando SUMAR.SI.CONJUNTO.

Te adjunto el archivo así reorganizado, creo que es más operativo. (ten en cuenta que he eliminado datos. He dejado varios meses para el ejemplo.)

Un saludo

AdjuntoTamaño
File radiacion_mensual_horaria.xlsx498.88 KB
pumuky
Imagen de pumuky
Offline
última acción: Hace 1 año 6 meses
alta: 25/05/2016 - 06:41
Puntos: 45
Gracias

Muchas gracias, no lo habia pensado así, pero funciona, que es lo importante.

Un saludo.