Suma rango con diferentes columnas

3 envíos / 0 nuevos
Último envío
rocaog
Imagen de rocaog
Offline
última acción: Hace 3 semanas 5 días
alta: 25/01/2018 - 13:25
Puntos: 35
Suma rango con diferentes columnas

Muy buenas, 

quiero hacer una suma de diferentes columnas. El problema que tengo es que el valor suma_rango no me acepta seleccionar diferentes columnas, solo me respeta y suma la primera.

Ejemplo. Quiero hacer esta formula:

SUMAR.SI(rango;criterio;rango_suma) es decir, rango(A2:A300); Criterio (enero); rango_suma(columna C +Columna D +...)

 

En ese rango_suma he probado con diferentes formulas que indicáis en otros hilos pero no me funciona. Tengo excel 2007.

He probado a indicar:

(suma(C2:C300)+SUMA(D2:D300)+...

C2:C300,D2:D300,....

=SUMAR.SI(rango;criterio;rango_suma1)+SUMAR.SI(rango;criterio;rango_suma2)+....

=SUMA(SUMAR.SI(rango;criterio;rango_suma1)+SUMAR.SI(rango;criterio;rango_suma2)+....


Estaré muy agradecido de vuestras respuestas. Desde ya me disculpo si no era un nuevo hilo la ubicación de esta consulta.

Un saludo,

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 1 hora 24 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 9585
La solución que das de

La solución que das de colocar un SUMAR.SI por cada columna a sumar es la solución. En el caso de utilizar la función SUMA, como haces en el último ejemplo, deberías utilizar un punto y coma entre cada SUMAR.SI en vez de un +. Esto te permitiría aprovechar las ventajas de utilizar la función SUMA, pero no es necesario.

 

El comportamiento que dices de tomar únicamente el resultado de la primera columna es el normal.

Un saludo

rocaog
Imagen de rocaog
Offline
última acción: Hace 3 semanas 5 días
alta: 25/01/2018 - 13:25
Puntos: 35
Gracias

Muchas gracias. Perfecto. Así si!