Promediar con varias condiciones

5 envíos / 0 nuevos
Último envío
Mati10
Imagen de Mati10
Offline
última acción: Hace 4 meses 20 horas
alta: 03/07/2018 - 14:15
Puntos: 45
Promediar con varias condiciones

Hola! Necesito confeccionar una planilla de calificaciones, la cual tiene 7 notas parciales y una nota integradora por semestre. Las notas son ingresadas por el usuario. Hay dos promedios por sacar, el promedio final anual y la calificación final.
El primero ya lo resolví, ya que es un promedio común solo que redondeado a 0,50; en el segundo es que necesito que me ayuden: el promedio se debe mostrar solo si se presentan estas condiciones...
-Tanto las notas parciales como las integraciones deben ser 7 o más, si el usuario ingresa aunque sea una nota menor a 7 no se muestra la calificación final. (Tener en cuenta que el usuario puede o no ingresar las 7 notas parciales)
-la otra condición es que las integraciones también deben ser de 7 o más y tienen que estar si o si las dos para que se muestre la calificación final.
No puedo dar con clavo. Porfa Ayudaaaaa!!!

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 12 horas 59 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9595
SI

puedes utilizar la función MIN para calcular la nota mínima de todas las existentes, y si es menor que 7 no calculas

=SI(MIN(tusnotas)<7;"nada";promedio(tusnotas))

Tanto la función MIN como Promomedio sólo tienen en cuenta las celdas con datos, así que si no hay nota no afectarán al resultado.

 

Sobre las otras dos notas, de integraciones que tienen que estar sí o sí las dos, puedes usar la función ESBLANCO para saber si una celda está vacía o no, con la función O puedes comprobar ambas (si o una es blanca o la otra es blanco, entonces nada)

=SI(O(ESBLANCO(integracion1);ESBLANCO(integracion2));"nada";....)

 

 

Data Tools Suite
datos y tablas con Excel

Mati10
Imagen de Mati10
Offline
última acción: Hace 4 meses 20 horas
alta: 03/07/2018 - 14:15
Puntos: 45
Muchas gracias por la ayuda

Muchas gracias por la ayuda pacomegia!

Te cuento andan bárbaro las dos funciones que me dejaste y cumplen con los requisitos que necesito. Ahora bien he intentado aunarlas, ya que las necesito juntas en la celda de "calificacion final", y no me sale. Te envío la funcion utilizada por si me puedes corregir...Saludos y nuevamente gracias!

=SI(O(ESBLANCO(O12);ESBLANCO(W12));SI(MIN(H12:W12)<7;"";PROMEDIO(H12:W12)))

...también prove de la siguiente manera:

=SI(O(ESBLANCO(O12);ESBLANCO(W12);MIN(H12:W12))<7;"";PROMEDIO(H12:W12))

...y de otras formas que directamente ni me da un resultado y excel me tira un cartel.

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 12 horas 59 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9595
pues se trata de poner una

pues se trata de poner una dentro de la otra, creo que te falta añadir un "" adicional para el caso de que las celdas O12 o W12 estén vacías

=SI(O(ESBLANCO(O12);ESBLANCO(W12));"nada";SI(MIN(H12:W12)<7;"nada";promedio(H12:W12)))

 

Data Tools Suite
datos y tablas con Excel

Mati10
Imagen de Mati10
Offline
última acción: Hace 4 meses 20 horas
alta: 03/07/2018 - 14:15
Puntos: 45
Me había ahogado en un vaso

Me había ahogado en un vaso con agua...ja...Muchas gracias por tu ayuda pacomegia!!!

Tambien le puse la funcion MULTIPLO.SUPERIOR, me salió bien...jaja...