Mejorar la Función SI con Función SI y BuscarV

2 envíos / 0 nuevos
Último envío
SALAVERRINO
Imagen de SALAVERRINO
Offline
última acción: Hace 2 meses 2 semanas
alta: 24/05/2016 - 15:59
Puntos: 185
Mejorar la Función SI con Función SI y BuscarV

Buenas tardes a los integrantes de este prestigioso foro, en esta ocasión recurro a uds para solicitar su apoyo en como mejorar las siguientes formulas que detallo a continuación:

FORMULA EN CELDA P2

Cuando la fórmula es evaluada

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19=BASE_AUXILIAR!$B$20=BASE_AUXILIAR!$B$21=BASE_AUXILIAR!$B$22=BASE_AUXILIAR!$B$23=BASE_AUXILIAR!$B$24=BASE_AUXILIAR!$B$25=BASE_AUXILIAR!$B$26=BASE_AUXILIAR!$B$27=BASE_AUXILIAR!$B$28=BASE_AUXILIAR!$B$29=BASE_AUXILIAR!$B$30=BASE_AUXILIAR!$B$31=BASE_AUXILIAR!$B$32=BASE_AUXILIAR!$B$33=BASE_AUXILIAR!$B$34=BASE_AUXILIAR!$B$35=BASE_AUXILIAR!$B$36=BASE_AUXILIAR!$B$37=BASE_AUXILIAR!$B$38=BASE_AUXILIAR!$B$39=BASE_AUXILIAR!$B$40=BASE_AUXILIAR!$B$41=BASE_AUXILIAR!$B$42=BASE_AUXILIAR!$B$43=BASE_AUXILIAR!$B$44=BASE_AUXILIAR!$B$45=BASE_AUXILIAR!$B$46=BASE_AUXILIAR!$B$47);0;E2))

G2 no contiene los criterios: 01: WINCHERO  (hoja base_auxiliar B2) -- 02: WINCHERO T (hoja base_auxiliar B3) -- 03: MURO (hoja base_auxiliar B4) -- 04: MURO T hoja base_auxiliar B5) -- 05 BODEGUERO (hoja base_auxiliar B6) -- 06 BODEGUERO T (hoja base_auxiliar B7)

 

Asigna el valor de la celda E2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

formula desarrollada en celda Q2: =SI.ERROR(SI(G2="";"";SI(G2=AAA;BUSCARV(G2;BASE_AUXILIAR!$B$8:$B$47;1;FALSO);));E2)

Utilice:

 

Nombre de Rango: AAA (base_auxiliar D2:D7) y para BUSCARV (base_auxiliar B8:B47) y se hay mejor opción de mejora acepto ideas.

FORMULA EN CELDA S2

Cuando la fórmula es evaluada:

=SI(G2="";"";SI(O(G2=BASE_AUXILIAR!$B$2;G2=BASE_AUXILIAR!$B$4;G2=BASE_AUXILIAR!$B$6;G2=BASE_AUXILIAR!$B$8;G2=BASE_AUXILIAR!$B$9;G2=BASE_AUXILIAR!$B$10;G2=BASE_AUXILIAR!$B$11;G2=BASE_AUXILIAR!$B$12;G2=BASE_AUXILIAR!$B$13;G2=BASE_AUXILIAR!$B$14;G2=BASE_AUXILIAR!$B$15;G2=BASE_AUXILIAR!$B$16;G2=BASE_AUXILIAR!$B$17;G2=BASE_AUXILIAR!$B$18;G2=BASE_AUXILIAR!$B$19;G2=BASE_AUXILIAR!$B$20;G2=BASE_AUXILIAR!$BF$21;G2=BASE_AUXILIAR!$B$22;G2=BASE_AUXILIAR!$B$23;G2=BASE_AUXILIAR!$B$24;G2=BASE_AUXILIAR!$B$25;G2=BASE_AUXILIAR!$B$26;G2=BASE_AUXILIAR!$B$27;G2=BASE_AUXILIAR!$B$28;G2=BASE_AUXILIAR!$B$29;G2=BASE_AUXILIAR!$B$30;G2=BASE_AUXILIAR!$B$31;G2=BASE_AUXILIAR!$B$32;G2=BASE_AUXILIAR!$B$33;G2=BASE_AUXILIAR!$B$34;G2=BASE_AUXILIAR!$B$35;G2=BASE_AUXILIAR!$B$36;G2=BASE_AUXILIAR!$B$37;G2=BASE_AUXILIAR!$B$38;G2=BASE_AUXILIAR!$B$39;G2=BASE_AUXILIAR!$B$40;G2=BASE_AUXILIAR!$B$41;G2=BASE_AUXILIAR!$B$42;G2=BASE_AUXILIAR!$B$43;G2=BASE_AUXILIAR!$B$44;G2=BASE_AUXILIAR!$B$45;G2=BASE_AUXILIAR!$B$46;G2=BASE_AUXILIAR!$B$47);0;K2))

G2 contiene los criterios: 02: WINCHERO T (hoja base_auxiliar B3) -- 04: MURO T (hoja base_auxiliar B5) -- 06 BODEGUERO T (hoja base_auxiliar B7)

Asigna el valor de la celda K2, y para el resto de criterios desde la hoja base_auxiliar (B8:B47) será 0 (cero)

Y es ahí donde quisiera usar Función SI y Función BUSCARV como se aprecia la formula en celda S2 o quizás haya otro método.

Desde ya agradezco y apoyo y colaboración.

AdjuntoTamaño
File funcion_si_con_buscarv.xlsx29.51 KB
pacomegia
Imagen de pacomegia
Offline
última acción: Hace 15 horas 53 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10460
¿la fórmula funciona?

¿la fórmula funciona? entonces no la toques

Es difícil de comprender una fórmula tan larga, y más para alguien no familiarizado con la realidad que hay detrás del modelo que representa tu hoja de cálculo.

 

Data Tools Suite
datos y tablas con Excel