Macro que realicé filtros de si anidados

2 envíos / 0 nuevos
Último envío
mireya85
Imagen de mireya85
Offline
última acción: Hace 2 meses 4 semanas
alta: 23/04/2018 - 21:08
Puntos: 25
Macro que realicé filtros de si anidados

Formula o macro para filtrar  estas tres variables.

 

·       Filtro en ceros columna “B”

·       Todo lo que este ocupado en la columna “C” y tenga las claves “LVMUE001, LVMUE032, LVEMPLE”

·       Lo que contenga la columna “A” lo que diga “HADDAD” debe decir “VARIOS  HADDAD” y lo que tenga “LEVI´S” debe decir “Varios” y todo lo que tenga la palabra “REENVASADO” PASA IGUAL COMO REENVASADO

 

En la columna “d” es como debe de quedar. Esta en rojo

Existe una fórmula para crear esto o una macro ya que se hace de forma manual 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 7 horas 37 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 9095
SI

supongo que todo esto lo puedes hacer con la función SI aplicada varias veces. tal vez con la función O e Y para comparar varios casos

por ejemplo para cambiar el valor cuando B2 sea cero, si no es cero se deja el valor de A2 tal cual

SI(B2=0;ya veremos lo que hacemos;A2)

la funcion Y permite comparar cuando B2 sea 0 Y cuando además en C tengamos una de las claves que te interesan, como son varias claves, puedes utilizar la función O para ver si es una u otra

SI(Y(B2=0;O(C2="LVMUE001";C2="LVMUE032";C2="LVEMPLE"));ya veremos lo que hacemos;A2)

y ¿qué es lo que tenemos que hacer cuándo se cumpla la condición? pues volvemos a comparar:

SI(A2="HADDAD";"VARIOS HADDAD";otros casos)

otros casos que podemos tener, pues otra comparación con SI:

SI(A2="LEVI´S";"Varios";otros casos)

y finalmente, dejamos lo que haya en A2


Al final, será algo parecido a esto, a lo que tendrás que añadir el resto de casos particulares, o algún control de errores para cuando en tu columna C tienes #N/A, etc. bueno, es sólo una idea:

=SI(Y(B2=0;O(C2="LVMUE001";C2="LVMUE032";C2="LVEMPLE"));SI(A2="HADDAD";"VARIOS HADDAD";SI(A2="LEVI´S";"Varios";A2));A2)

 

 

Data Tools Suite
datos y tablas con Excel