Importante. BUSCARV varios libros de Excel

2 envíos / 0 nuevos
Último envío
visitante (no verificado)
Imagen de visitante
Importante. BUSCARV varios libros de Excel

Estimado,

Necesito saber si puedo buscarv en varios libros de excel ?  ejemplo de mi archivo : Necesito encontrar lo que esta escrito al ultimo de las columnas ( Columna Z5 ).

que error hay en esta formula ? o no se puede buscarv en muchos libros ( tengo 7 libros ) ? 

o habra otra formula para buscar en tantos libros ? ( tengo 7 libros )

=SI(E7="HYUNDAI2";BUSCARV(I7;'[Cordillera (AURA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO);BUSCARV(I7;'[Iqq-Hospicio(ALIANZA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO));BUSCARV(I7;'[Kainita(AURA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO)));BUSCARV(I7;'[Patache(ALIANZA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO))));BUSCARV(I7;'[Patillos(ALIANZA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO)))));BUSCARV(I7;'[Patache-Patillo(ALIANZA).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO))))));BUSCARV(I7;'[Tramites(interno).xls]PROGRAMA'!$A$5:$Z$100;26;FALSO)))))))

Porfavor necesito ayuda.

Desde ya muchas gracias  mi estimado Amigo.

Nota: Todos los libros tienen información diferente de A5-A100 hasta Z5-Z100  pero son el mismo  modelo   

Atte.

DEV.

AdjuntoTamaño
Image icon sin_titulo.png171.51 KB
pacomegia
Imagen de pacomegia
Offline
última acción: Hace 1 hora 12 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 7590
sí y no

Hola:

BUSCARV sólo busca en una matriz, es decir, que no puedes buscar en 7 rangos que estén en 7 libros distintos.

Así que tendrás que utilizar 7 fórmulas para buscar en cada uno de los 7 sitios.

¿qué pasa si lo que buscas no está en ningún sitio? pues obtendrás un error #N/A

¿qué quieres que pase si lo que buscas está en más de un sitio, o en los 7?

 

Yo utilizaría la función SI.ERROR para interceptar los casos en los que no lo encuentra para no devolver un #N/A

En este caso con 7 libros probablemente anidaría las funciones SI.ERROR 

=SI.ERROR(buscarV( 1ª tabla); SI.ERROR(buscarV( 2ª tabla );SI.ERROR(buscarV( 3ª tabla );SI.ERROR(buscarV( 4ª tabla );SI.ERROR(buscarV( 5ª tabla );SI.ERROR(buscarV( 6ª tabla );SI.ERROR(buscarV( 7ª tabla );"no lo encuentro")))))))

si da error al buscar en la tabla 1, entonces pasa a la tabla 2,
si da error al buscar en la tabla 2, entonces pasa a la tabla 3, ...

 

Data Tools Suite
datos y tablas con Excel