Error autofill

1 post / 0 nuevos
Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 1 mes 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4903
Error autofill

Buenos días

Tengo el siguiente código

Range("A8").FormulaLocal = "=SI(B7=""""|""""|CONTAR($B$8:B8))"
Range("a8").AutoFill Destination:=Range("a8:a" & Range("b" & Rows.Count).End(xlUp).Row)

Bueno mediante está macro pongo la fórmula en la columna A8 y lo copia hasta el final según la orden, todo bien asta ahí, solo que cuando es una sola fila con datos me sale el mensaje de error

Se ha producido el error '1004' en tiempo de ejecución : Error en el método AutoFill de la clase Range.

¿Cómo puedo evitar este error?

Gracias

 

Jesús

Etiquetas: