Dos Calculos con Funciones en Celda

7 envíos / 0 nuevos
Último envío
Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 meses 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4938
Dos Calculos con Funciones en Celda

Estimados amig@s:

Tengo el siguiente problemita, esta es la formula que introduje:

=SI(E2="TM"|S2*AD2↑SIE2="EJ"|E2/AD2|0/100)|REDONDEAR.MAS(E2/AD2|0/100))

Esta formula esta en la celda X2 que uso para sacar porcentajes  y esta celda esta con el formato contabilidad con dos decimales , pero si en la celda E2 estan los valores TM o EJ lo mantenga ese formato de contabilidad, caso contrario que lo redondee al inmediato superior sin decimales.

Ayuda por favor 

SAludos cordiales

Jesús

 

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 12 horas 16 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 8685
Re: Dos Calculos con Funciones en Celda

Mediante una fórmula puedes redondear el valor pero no puedes modificar el formato con el que se presenta el resultado, a no ser que emplees la función TEXTO y conviertas tu número en un texto, claro que entoces no podrás operar con él, porque deja de ser un número, así que no te lo recomiendo.

Así que si redondeas al inmediato superior, si la celda tiene formato con dos decimales aparecerá coma (o punto) cero cero

 

no entiendo esos caracteres  | y ↑ que hay en tu fórmula

¿utilizas | como separador de listas?

supongo que falta un paréntesis de apertura también en SIE2="EJ"  ¿Será SI(E2="EJ"...   ?

 

Data Tools Suite
datos y tablas con Excel

Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 meses 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4938
Re: Dos Calculos con Funciones en Celda

Estimado Pacomegia:

Te comento que hice la siguiente formula que si me sirvio, espero que a otros tamb ien les sirva.

Saludos coridales

Jesús

La formula es:

 =SI(E18="EJ"|S18*AD18/100|SI(E18="TM"|S18*AD18/100|REDONDEAR.MENOS(S18*AD18/100|0))) 

Jesus Martinez Plantarosa

Cron
Imagen de Cron
Offline
última acción: Hace 2 días 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 10035
Re: Dos Calculos con Funciones en Celda

Si utilizas VALOR(TEXTO( ...

A lo mejor funciona

Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 meses 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4938
Re: Dos Calculos con Funciones en Celda

Estimado Cron y como seria la función completa?

Saludos

Jesús

Jesus Martinez Plantarosa

Cron
Imagen de Cron
Offline
última acción: Hace 2 días 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 10035
Re: Dos Calculos con Funciones en Celda

Pues algo así como:

 

 

=texto(FórmulaQueTúNecesites;"0,00")


Cuando quieras operar con ella, simplemente introdúcela en la fórmula como harías con cualquier otra:


=C2*3


Si en C2 tenías el texto anterior, Excel operará con su valor sin problemas, al menos con la versión de Excel 2010.



Un saludo

Jesús Martínez ...
Imagen de Jesús Martínez Plantarosa
Offline
última acción: Hace 3 meses 2 semanas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 31/03/2013 - 17:15
Puntos: 4938
Re: Dos Calculos con Funciones en Celda

Buena idea gracias mil

saludos cordiales

Jesús

Jesus Martinez Plantarosa