Desafío excel búsqueda matriz devolver valor anterior con varios valores

5 envíos / 0 nuevos
Último envío
JoseGar
Imagen de JoseGar
Offline
última acción: Hace 2 meses 1 semana
alta: 08/12/2018 - 13:07
Puntos: 45
Desafío excel búsqueda matriz devolver valor anterior con varios valores

Tengo una matriz donde la columna A aparecen el número de reserva, desde 1 hasta n. En la columna B aparece el hotel donde se ha producido esa reserva. En la columna C aparece el agente que va a limpiar esa reserva.

Lo que necesito, es saber quién limpió en la reserva anterior a cada reserva para poder aplicar la valoración que recibió ese agente.

En el ejemplo que pongo en el archivo adjunto, la valoración de la reserva 10, hay que aplicarla al agente F, ya que fue quien limpió la última vez y la valoración de la reserva 27 hay que aplicarla al agente V.

Hay que tener en cuenta que las valoraciones de cada huésped en cuanto a limpieza corresponden a la última limpieza, no a la limpieza de ésa reserva, ya que esa limpieza será "disfrutada" por el siguiente.

Gracias!

 

AdjuntoTamaño
File agente_limpieza.xlsx10.29 KB
x (no verificado)
Imagen de x
la ultima limpieza la hizo....

espero te sirva

AdjuntoTamaño
File agente_limpieza.xlsx15.97 KB
Cron
Imagen de Cron
Offline
última acción: Hace 1 hora 29 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 11670
He colocado en la columna D

He colocado en la columna D la siguiente fórmula (copio la celda D2):

=INDICE(C:C;MAX(($B$1:B1=B2)*FILA($B$1:B1)))

Esto funciona como fórmula matricial, es decir, la tecleas y para introducirla debes pulsar CTRL + MAYS + ENTER. No basta con pulsar ENTER o TAB.

Si lo haces correctamente, te aparecerá entre llaves {}

Luego la arrastras hasta abajo.

Las primeras te devolverán "Agente" porque no hay ningún agente de limpieza anterior, pero después te tomará siempre el último agente que limpió.

 

Un saludo

JoseGar
Imagen de JoseGar
Offline
última acción: Hace 2 meses 1 semana
alta: 08/12/2018 - 13:07
Puntos: 45
Mil gracias!!Crack!

Mil gracias!!

Crack!

JoseGar
Imagen de JoseGar
Offline
última acción: Hace 2 meses 1 semana
alta: 08/12/2018 - 13:07
Puntos: 45
Mil gracias tambien! Funciona

Mil gracias tambien! Funciona perfecto ;)