Ayuda con una formula para contar celdas vacías con ciertas condiciones

3 envíos / 0 nuevos
Último envío
ALICASTILLO
Imagen de ALICASTILLO
Offline
última acción: Hace 2 semanas 5 días
alta: 17/01/2018 - 22:21
Puntos: 35
Ayuda con una formula para contar celdas vacías con ciertas condiciones

Tengo en la hoja1, en la columna B, 9 Delitos,(homicidio, lesiones personales,etc) y en la Columna H, las horas en que se cometieron esos delitos, ahora bien deseo una formula que me cuente las celdas vacías por cada uno de esos delitos y me arroje su resultado en una tabla de frecuencias que está en la hoja 2.

En la hoja2, necesito una formula en la columna G que vea en la hoja1 cada uno de los delitos de la Columna B, y me cuente cuantas celdas están vacías por cada uno de esos delitos, tuve que hacerlo numérico, pero necesito una formula. Nota: Las demás columnas tienen formulas. De antemano agradecido si alguien me ayuda, Gracias

AdjuntoTamaño
Image icon diapositiva1.jpg109.96 KB
Image icon diapositiva2.jpg107.14 KB

Etiquetas: 

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 11 horas 8 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 8115
CONTAR.SI.CONJUNTO

Creo que la función que necesitas es CONTAR.SI.CONJUNTO, algo parecido a esto:

=CONTAR.SI.CONJUNTO(Hoja1!B14:B29;A14;Hoja1!H14:H29;"")

La condición para la columna B del tipo de delito la tienes en la columna A de la hoja 2 

La condición para las celdas vacías de tu columna H sería "" (una cadena vacía)

En el ejemplo he puesto la fórmula para las filas de la 14 a la 29 que es lo que se ve en la imagen, tendrás que ajustarlo a tu caso concreto

 

Data Tools Suite
datos y tablas con Excel

ALICASTILLO
Imagen de ALICASTILLO
Offline
última acción: Hace 2 semanas 5 días
alta: 17/01/2018 - 22:21
Puntos: 35
GRACIAS POR LA FORMULA, SI ME SIRVIÓ

SI ME SIRVIÓ LA FORMULA, LE HICE UNOS CAMBIOS, EN VEZ DE CONTAR.SI.CONJUNTO, UTILICÉ

SUMAR.SI.CONJUNTO

=SUMAR.SI.CONJUNTO('Hoja1'!$BF$9:$BF$188;'Hoja1'!$B$9:$B$188;DETALLE!$H34;'Hoja1'!$H$9:$H$188;"")

DONDE LA COLUMNA BF ES LA CANTIDAD DE HECHOS DELICTIVOS, LA COLUMNA B DE LA HOJA1 SON LOS TIPOS DE

DELITOS (ROBO, HURTO, HOMICIDIO, ETC), TUVE QUE COLOCAR EN UNA HOJA NUEVA QUE NOMBRÉ DETALLE, LOS

TIPOS DE DELITOS EN LA COLUMNA H A PARTIR DE LA FILA 30, DE MODO TAL QUE ME VEA EN LA HOJA2 DE LA IMAGEN

LOS TIPOS DE DELITOS EN ESE ORDEN Y ME SUME ASI LAS CELDAS EN BLANCO. Y CON ESTE EJEMPLO SI ME SUMÓ

DICHAS CELDAS EN BLANCO.

GRACIAS