Problema con función concatenar y si anidada

5 envíos / 0 nuevos
Último envío
eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 2 semanas 3 días
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 505
Problema con función concatenar y si anidada

 

Hola buenas.

Tengo problema en el resultado  Fila2 en M2, por lo que tengo visto es por la función concatenar de E2 con los valores 1 y 2 solo me da bien si esta el valor X ¿??

En Fila 6 la prueba esta que manualmente cambio los datos en E6 y el resultado en M6 es el esperado.

Salud2…..

AdjuntoTamaño
File foro_concatenar.rar6.33 KB
Cron
Imagen de Cron
Offline
última acción: Hace 1 día 10 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 9865
Tú has puesto:=SI(Y(K2=1;L2=

Tú has puesto:

=SI(Y(K2=1;L2="X");2;SI(Y(K2="X";L2=1);2;SI(Y(K2=1;L2=2);"X";SI(Y(K2=2;L2=1);"X";SI(Y(K2="X";L2=2);"X";SI(Y(K2=2;L2="X");1;0))))))

 

El condicional distingue entre texto y números. Le estás preguntando si en K2 hay un 1 número, y Excel te dice que no, porque al ser el resultado de una función concatenar, entonces es 1 texto. Te recomiendo que todo lo manejes en el mismo formato (si todos los números son texto, pues todos texto y no unos como número y otros como texto. De hecho, salvo que tengas interés en otra cosa, te recomiendo que siempres utilices los números con formato número.

En tu caso, en la celda E2 tienes esto:

=CONCATENAR(A2;B2;C2)

Y yo pondría esto:

=VALOR(CONCATENAR(A2;B2;C2))

De esta manera te funcionará bien.

 

Un saludo

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 2 semanas 3 días
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 505
Ahora con X no va

Pues ahora con 1 y 2 va pero cuando esta el valor X en A:C no va, pruebalo y lo veras.

De momento una forma de slir del paso, mejor que lo que tenia hasta tener otra solucion es en K2 =SI.ERROR(SI(E2=E2;E2;E2);"X")

 

 

Salud2.

Cron
Imagen de Cron
Offline
última acción: Hace 1 día 10 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 9865
Tienes razón. También lo

Tienes razón. También lo puedes poner en la misma celda E2:

=SI.ERROR(VALOR(CONCATENAR(A2;B2;C2));CONCATENAR(A2;B2;C2))

 

O puedes tratarlo todo siempre como texto, dejando la celda E2 como la tenías, y cambiando los condicionales L2 y M2, poniendo entre comillas los 1 y los 2:

=SI(Y(K2="X";H2="X");"1";SI(Y(K2="2";H2="2");"1";"X"))

=SI(Y(K2="1";L2="X");"2";SI(Y(K2="X";L2="1");"2";SI(Y(K2="1";L2="2");"X";SI(Y(K2="2";L2="1");"X";SI(Y(K2="X";L2="2");"X";SI(Y(K2="2";L2="X");"1";0))))))

 

Un saludo

eugeniocol
Imagen de eugeniocol
Offline
última acción: Hace 2 semanas 3 días
Nivel 1 - 200 puntos
alta: 29/08/2017 - 17:21
Puntos: 505
ya lo probe y no

Ya lo probe en su momento poner 1 y 2 entre "" y cuando pones X en A:C en M no va.

Bueno de momento lo dejo con:

=SI.ERROR(VALOR(CONCATENAR(A2;B2;C2));"X")

Que lios mas tontos se presentan cuando menos te lo esperas jij........

 

Salud2...