Promedios sin incluir ceros ni celdas en blanco

22 envíos / 0 nuevos
Último envío
carlosmciria
Imagen de carlosmciria
Offline
última acción: Hace 2 años 1 mes
alta: 27/04/2012 - 12:02
Puntos: 45
Promedios sin incluir ceros ni celdas en blanco

Hola,

Quiero hacer un promedio de varios datos sin que tenga en cuenta los ceros ni los espacios en blanco.

El problema es que quiero hacer el promedio de datos que están en celdas salteadas y con la fórmula "PRMEDIO.SI", al poner el rango no sé cómo poner las celdas salteadas.

¿Cómo puedo hacer ese promedio de celdas salteadas sin que tenga en cuenta ceros ni espacios en blanco?

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 9 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Re: Promedios sin incluir ceros ni celdas en blanco

Hasta donde yo sé, la función PROMEDIO y sus derivadas (PROMEDIO.SI, PROMEDIO.SI.CONJUNTO) no tienen en cuenta los espacios vacíos. Sí que tienen en cuenta los ceros, porque los considera datos.

Si sustituyes los ceros por "", entonces no lo tiene en cuenta.

 

Si utilizas PROMEDIOA, entonces cualquier valor no numérico lo sustituye por el valor 0, y hace la media de los valores resultantes.

 

Hasta donde se me ocurre, lo mejor es poner una fórmula en la que si el resultado es cero, escriba "", '0 o "0"

De esta manera, considera que el valor 0 es texto y no lo computa a la hora de hacer la media.

 

 

Un saludo

carlosmciria
Imagen de carlosmciria
Offline
última acción: Hace 2 años 1 mes
alta: 27/04/2012 - 12:02
Puntos: 45
Re: Promedios sin incluir ceros ni celdas en blanco

Gracias Cron, pero no sé cómo poner una fórmula en la que si el resultado es cero, escriba "0".

La fórmula PROMEDIO.SI soluciona este problema, porque pongo la condición de que sea <>0. El problema es que los datos están salteados, y entonces al elegir el rango en PROMEDIO.SI no me deja coger celdas salteadas, como sí se puede hacer en la fórmula PROMEDIO.

Otra opción que he pensado es usar SUMA/CONTAR.SI, pero pasa lo mismo, en la fórmula CONTAR.SI no puedo coger un rango de celdas salteadas.

Cron
Imagen de Cron
Offline
última acción: Hace 9 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Re: Promedios sin incluir ceros ni celdas en blanco

Pues la fórmula sería algo así:

 

=SI(Expresión=0;"0";Expresión)

 

Sustituyendo Expresión por la fórmula que te interese en cada caso.

 

En cuanto a lo de las celdas salteadas, si se me ocurre algo lo comento. En cualquier caso, ¿No sería más fácil extraer los datos concretos primero y solo después aplicar la función del promedio?

 

 

Saludos

carlosmciria
Imagen de carlosmciria
Offline
última acción: Hace 2 años 1 mes
alta: 27/04/2012 - 12:02
Puntos: 45
Re: Promedios sin incluir ceros ni celdas en blanco

Muchas gracias Cron.

Al final he hecho eso, extraer los datos y calcular los promedios sobre los datos extraídos.

Diego (no verificado)
Imagen de Diego
=SUMA(C3:C50)/CONTAR(C3:C50

=SUMA(C3:C50)/CONTAR(C3:C50)

las que no tiene valor por estar vacias no las incluye

GATO
Imagen de GATO
Offline
última acción: Hace 1 año 5 meses
Nivel 1 - 200 puntos
alta: 14/12/2011 - 00:24
Puntos: 260
Promedios sin incluir ceros ni celdas en blanco

Hola.

A mi me funciona usar esta formula.

Te adjunto hoja Excel. espero que te sirva

 {=PROMEDIOA(SI(Matriz o Rango de celdas=0;"";Matriz o Rango de Celdas))}

 

Joel (no verificado)
Imagen de Diego
Estimado GATO mas corto y

Estimado GATO mas corto y efectivo te envío esta función.

=PROMEDIO.SI(B4:B19,"<>0")

Joel (no verificado)
Imagen de Diego
Prueba con esta función que es mas corta y efectiva.

=PROMEDIO.SI(A4:A20,"<>0")

El rango ya tu lo acomodas a tu beneficio.

Saludos

cesar.ivan
Imagen de cesar.ivan
Offline
última acción: Hace 2 años 11 meses
alta: 07/06/2014 - 21:47
Puntos: 260
Cierto! Funciona y da el

Cierto! Funciona y da el mismo resultado del metodo anterior! 

Ingrid (no verificado)
Imagen de Diego
Cálculo de Promedio sin ceros en tabla dinámica.

tengo como resultado 50 como promedio en una tabla dinámica, pero no es real,  con 36,ya que, en la hoja base existen filas con valores cero que no se desean se considere para el cálculo del promedio en la tabla dinámica. Sería fácil, si en la hoja de datos base se usara promedio.si..pero no es solución ya que con muchas más columnas con campos a calcular. Existe EN la tabla dinámica un promedio.si ?? para filtrar que no considere las filas que están con valor en cero?. Gracias por la ayuda.

amanda (no verificado)
Imagen de Diego
hola

GRACIAS ME AYUDO MUCHOO

Davidar (no verificado)
Imagen de Diego
gracias

Muchas gracias, resulto.

Tambien tenia el mismo problema.

ramon (no verificado)
Imagen de Diego
promedio

excelente

Franco (no verificado)
Imagen de Diego
...

TE ADORO FUERTE!!

visitante (no verificado)
Imagen de Diego
Hola, y como se hace para

Hola, y como se hace para omitir columnas completas, si el promedio incluye un cuadro de celdas que incluyen filas y columnas. POr ejemplo, si tengo datos que van desde A10 hasta M30, pero no deseo promediar los datos de las columnas E, H y J. Como hago en ese caso?

Gracias

Cron
Imagen de Cron
Offline
última acción: Hace 9 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Seleccionando únicamente las

Seleccionando únicamente las columnas a promediar.

=PROMEDIO(E10:E30;H10:H30;J10;J30)

Un saludo

lacortadaduke (no verificado)
Imagen de Diego
convertir celdas vacias en cero, para promedio correcto

quisiera saber que funcion utilizar para transformar celdas VACIAS en valor "0", ya que debo realizar un promedio anual considerando que las celdas vacias sean un CERO.

gracias 

Cron
Imagen de Cron
Offline
última acción: Hace 9 horas 45 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Pongamos que los datos están

Pongamos que los datos están entre A1 y A10. Hasta donde yo sé, hay que montarte el cálculo a mano. Para eso sumaríamos todo lo que hay en las celdas y lo dividimos entre el total de celdas. Una manera rápida de calcular el total de celdas es contar la cantidad de celdas que tienen algún valor y sumarle la cuenta de celdas que están en blanco. Algo así como:

=SUMA(A1:A10)/(CONTAR(A1:A10)+CONTAR.BLANCO(A1:A10))

Un saludo

Jaime (no verificado)
Imagen de Diego
Funciona! Gracias

Funciona!

 

Gracias

Elena Moreno (no verificado)
Imagen de Diego
Agradecimiento

Le agradezco mucho, fue de utilidad su formula.

 

Saludos desde La Ceiba, Hondruas

 

Armando (no verificado)
Imagen de Diego
PROMEDIO CELDAS NO CONTIGUAS

 

 

Para mi caso, es que quiero que me haga el promedio de celdas que no son contiguas y que tengan algún valor, pero que no tenga en cuenta las que son 0. Yo creo que esta es la solución:

=(K13+N13+Q13+T13+W13)/(CONTAR.SI(K13;"<>0")+CONTAR.SI(N13;"<>0")+CONTAR.SI(Q13;"<>0")+CONTAR.SI(T13;"<>0")+CONTAR.SI(W13;"<>0"))