Cambiar nombre de hoja en formula por valor de celda

3 envíos / 0 nuevos
Último envío
Manu Márquez
Imagen de Manu Márquez
Offline
última acción: Hace 3 meses 3 semanas
alta: 27/02/2018 - 11:18
Puntos: 35
Cambiar nombre de hoja en formula por valor de celda

Buenos dias.

Necesitaria ayuda para lo siguiente. Estoy trabajando con un libro en el que introduzco los datos mensuales de clientes y agentes. Para ello tengo en el libro 12 hojas con nombres Ene, Feb... hasta Dic y tengo una hoja donde quiero hacer el resumen. Mediante la función SUMAR.SI.CONJUNTO tengo los datos, pero no se como cambiar la formula para que me sume los datos de la hoja correspondiente al mes que introduzco en una celda.

La fórmula es: SUMAR.SI.CONJUNTO(Ene!$L$2:$L$200;Ene!$I$2:$I$200;A6;Ene!$H$2:$H$200;$B$2) y lo que quiero es que se actualice según indique yo en una celda de la hoja resumen Ene, Feb... Dic.

He buscado por distitas webs, pero no encuentro lo que busco, lo que me hace preguntarme si realmente puedo hacer eso.

Gracias por vuestras respuestas!!!

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 1 día 15 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 8885
INDIRECTO

La función INDIRECTO es lo que necesitas

Esta función permite "concatenar" una referencia a una celda y que Excel lo entienda como una referencia

 

Data Tools Suite
datos y tablas con Excel

Manu Márquez
Imagen de Manu Márquez
Offline
última acción: Hace 3 meses 3 semanas
alta: 27/02/2018 - 11:18
Puntos: 35
Cambiar nombre de hoja en formula por valor de celda

¡¡Muchas gracias por tu pronta respuesta!!

Por si le sirve a alguien, esta es la fórmula: =SUMAR.SI.CONJUNTO(INDIRECTO("'"&$C$6&"'!"&"$E$2:$E$1000");INDIRECTO("'"&$C$6&"'!"&"$B$2:$B$1000");A8;INDIRECTO("'"&$C$6&"'!"&"$A$2:$A$1000");$B$4)

Me ha costado algo entender la sintaxis de la función INDIRECTO, pero una vez conseguido me encuentro otro problema y es que al tener 7 variables para la hoja resumen (la fórmula entera es sumar 7 veces la función SUMAR.SI.CONJUNTO), al sustituir la referencia en cada una de las variables no me deja anidar tantas en una sola fórmula. ¿Puede ser que tenga un cierto número de anidamientos esta función?

Gracias y saludos.

 

¡¡Error mio, se me olvidó una comilla que degeneraba la fórmula!!

Todo correcto.

Mil gracias.

Manu Márquez

Huelva