Buscar un valor o aproximado superio en una columna

9 envíos / 0 nuevos
Último envío
excel1977
Imagen de excel1977
Offline
última acción: Hace 3 años 2 meses
Nivel 1 - 200 puntos
alta: 19/11/2014 - 10:00
Puntos: 265
Buscar un valor o aproximado superio en una columna

Buenas a todos, es la primera vez que entro en el foro asi que gracias por adelantado.-

Mi pregunta es,

Tengo un valor en una celda, ( por ejemplo en la celda C7 = 18,2 )

Tengo dos columnas y lo que quiero es, buscar en la primera columna el valor de C7 y en caso de que no sea el mismo valor el siguiente superior, siempre en la primera columna. Cuando encuentre el valor buscado me tiene que devovlver el numero de la segunda columna.-

Ejemplo.-

C7 = 18.2

A1             A2

10.25         11

15              22

18              31

19.5           41

22              55

La fórmula tiene que devolverme 41, porque buscaría 18,2 pero como no está busca el siguiente superior, en este caso 19.5 y me devuelve el número de la siguiente columna, en este caso 41.

 

Gracias

 

Cron
Imagen de Cron
Offline
última acción: Hace 4 días 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12225
El problema lo tienes
excel1977
Imagen de excel1977
Offline
última acción: Hace 3 años 2 meses
Nivel 1 - 200 puntos
alta: 19/11/2014 - 10:00
Puntos: 265
Creo que no es igual

Hola y gracias por contestar, pero no veo que sea mi caso, te explico.-

No puedo cambiar de orden los valores y ponerlos de mayor a menor, sino que tengo que dejarlos de forma ascendente, o sea de menos a mas tal cual están en la columna.- El resto estal cual lo indico en el anterior mensaje, a ver si me podeis ecgar una mano, please.-

Saludos.

Cron
Imagen de Cron
Offline
última acción: Hace 4 días 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12225
Como ves en el otro hilo,

Como ves en el otro hilo, existe la función HALLAR, pero necesita que los datos estén ordenados de mayor a menor. Si no, da un error #N/A.

Se me ocurre hacerlo de otra manera. Podrías poner una línea en blanco encima de los datos, o si no utilizar la versión de primera línea de la fórmula que te pongo. La idea es poner a la derecha de cada fila de datos (en tu ejemplo sería la columna C) la fórmula que te pongo:

primera línea:

=SI(A1>C$7;B1;"")

Resto de líneas (está formulado para C2, luego habría que arrastrarlo al resto de la columna)

=SI(A2>=C$7;SI(SUMA(C$1:C1)=0;B2;"");"")

Esto lo que hace es detectar si el dato en A es igual o mayor que el que has introducido en la celda de control (en nuestro caso C7)

Si lo es, selecciona el dato de B. Si no, asigna un valor nulo (o lo más parecido a nulo que hay en Excel: "")

Si el valor es mayor, comprueba si ya se había asignado un valor antes. Si no es así, selecciona el valor de B. Si hay algún valor previo en B seleccionado, pues de nuevo asigna "".

El resultado se mostraría en otra celda en la que pones una fórmula que sume todos los valores. La suma de "" + "" + valor de B + ""... será el valor de B que se haya seleccionado.

Como es un poco lioso, te adjunto un pequeño ejemplo con tus datos.

Un saludo

AdjuntoTamaño
File buscamayor.xlsx10.36 KB
excel1977
Imagen de excel1977
Offline
última acción: Hace 3 años 2 meses
Nivel 1 - 200 puntos
alta: 19/11/2014 - 10:00
Puntos: 265
Va casi bien

Buenas de nuevo Cron, gracias por enviar el ejemplo pero sigue habiendo un problema, te comento.-

Cuando en la celda C7 busco por ejemplo el valor 13 , me tendría que dar un valor de 22, pero que pasa pues fijate que me suma 22+41 = 63 ??? Porque me salen dos valores en la fila C, solo me tendría que salir un valor no??? en mi caso solo el 22.-

Si pongo en C7 el valor de 10, es aun peor porque me suma tres valores de la columna C 11+31+55 = 97, cuando me tendría que salir solo 11.-

 

A ver si me puedes echar un cable con esto por favor.- Gracias.- 

Cron
Imagen de Cron
Offline
última acción: Hace 4 días 20 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 12225
Es cierto que subí la versión

Es cierto que subí la versión 1. Si te fijas, no corresponde con lo que escribí en el post.

Subo la versión corregida.

 

Saludos

AdjuntoTamaño
File buscamayor.xlsx10.36 KB
excel1977
Imagen de excel1977
Offline
última acción: Hace 3 años 2 meses
Nivel 1 - 200 puntos
alta: 19/11/2014 - 10:00
Puntos: 265
Buen trabajo

Gracias Cron, ahora esto va como un reloj.

 

Gracias.-

GATO
Imagen de GATO
Offline
última acción: Hace 3 años 1 semana
Nivel 1 - 200 puntos
alta: 14/12/2011 - 00:24
Puntos: 260
Buscar un valor o aproximado superio en una columna

HOLA: TE MANDO ESTE FICHERO COPIATE LA FORMULA, VERAS QUE FUNCIONA MUY BIEN

SALUDOS.

 

misael (no verificado)
Imagen de misael
MUCHAS GRACIAS LLEVABA ALGO

MUCHAS GRACIAS LLEVABA ALGO DE TIEMPO BUSCANDO UNA FORMULA ASI.