Buscar fecha en un rango

6 envíos / 0 nuevos
Último envío
leprita
Imagen de leprita
Offline
última acción: Hace 2 meses 2 semanas
Nivel 1 - 200 puntos
alta: 08/07/2010 - 11:04
Puntos: 247
Buscar fecha en un rango

Hola, uso una planilla de excel con varios datos, en el adjunto solo copie la parte que no puedo resolver.

Paso a explicar:

el primer dia del mes, como éste julio de 2017, cae un sabado. Yo los jueves separo cierta cantidad de dinero para ir al banco, para eso uso la funcion "diasem" para que me resalte a traves de una condicion ese mismo dia, o sea que la celda que diga "jueves" se ponga de color rojo.

En otra celda necesito obtener el formato de fecha de ese mismo dia, como por ejemplo éste jueves de la primer semana es el dia 6/7/2017 y asi me manejo durante el mes, separo la hoja en 4 semanas y busco el dia jueves.

Aca el problema, e usado las formulas (buscarv,  coincidir concatenada con la formula indice y demas), solo que no obtengo el valor deseado, o es un error o me da la fecha del año 1900.

Que formula tendria q usar para obtener en otra celda,en formato de fecha (6/7/2017), la celda que me diga jueves, en este caso?

Desde ya muchas gracias!!!

AdjuntoTamaño
File yaseexcel.xlsx10.43 KB

Etiquetas: 

Cron
Imagen de Cron
Offline
última acción: Hace 7 horas 27 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Seguramente estás utilizando

Seguramente estás utilizando algo como:

=BUSCARV("jueves";A3:B8;2;FALSO)

Sin embargo, esto te dará un error #N/A porque el valor "jueves" no existe entre los resultados de tu columna A. Lo que ves como "jueves" no es el valor real, sino el resultado de aplicar al resultado de tu fórmula (que en este caso es 5) el formato de fecha para que te responda el día de la semana con todas las letras.

Por lo tanto, tu fórmula correcta sería:

=BUSCARV(5;A3:B8;2;FALSO)

 

Nota curiosa:

DIASEM tiene un segundo parámetro por el que se puede elegir entre tres opciones:

-que el 1 sea domingo y cuente hasta el sábado 7
-que el 1 sea lunes y cuente hasta el domingo 7
-que el domingo sea el día 0 y cuente hasta el sábado 6

En versiones más modernas de Excel hay muchas opciones más, pudiendo dar como día 1 cualquier día de la semana.

 

Nota curiosísima:

Si le preguntas a Excel qué día de la semana era el 1 de enero de 1900, te dirá que domingo. Sin embargo era lunes. Esto se debe a un error que cometió Lotus 123 en su hoja de cálculo, donde no contemplaron que el año 1900 era bisiesto. Por lo tanto, son correctos todos los días posteriores al 1 de marzo de 1900. Cuando Microsoft lanzó Excel, tenía que competir con Lotus 123, y mantuvo el error intencionadamente por compatibilidad, para favorecer que la gente migrara entre un programa y el otro.

 

Un saludo

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 23 horas 36 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 7570
1900 no fue bisiesto

Hola:

Sin ánimo de ser el "enanito gruñón", sobre la nota curiosísima, resulta que el año 1900 no es bisiesto, porque es múltiplo de 100 pero no es múltiplo de 400.

https://es.wikipedia.org/wiki/A%C3%B1o_bisiesto

http://www.necesitomas.com/anios_bisiestos_excel

Así que el error puede ser que Lotus 123 considerase 1900 como bisiesto sin serlo. En cualquier caso es más gorda la limitación de no poder utilizar fechas anteriores a 1900

Prueba a poner 29/02/1900 en Excel. lo acepta como fecha,

Sin embargo, prueba a poner 29/02/2100. Excel no lo acepta como fecha (bien, porque ese día no existirá).

 

Data Tools Suite
datos y tablas con Excel

Cron
Imagen de Cron
Offline
última acción: Hace 7 horas 27 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 8840
Exacto, gracias Paco. Era

Exacto, gracias Paco. Era exactamente al revés. Lo consideraron bisiesto sin serlo.

El 1 de enero de 1900 es domingo para Excel, pero en realidad fue lunes.

Un saludo

chronot
Imagen de chronot
Offline
última acción: Hace 1 semana 1 día
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntos
alta: 30/01/2011 - 22:33
Puntos: 2692
Excelentes apreciaciones,

Excelentes apreciaciones, ¡muchas gracias Cron y Paco!

leprita
Imagen de leprita
Offline
última acción: Hace 2 meses 2 semanas
Nivel 1 - 200 puntos
alta: 08/07/2010 - 11:04
Puntos: 247
buscar celdas con fecha

Hola!!!!, muchisimas gracias!!!!, pero como se complica uno, eran tan facil!!!!!!!!