arrastrar funciones pero solo modificar una variable

6 envíos / 0 nuevos
Último envío
PABLITO
Imagen de PABLITO
Offline
última acción: Hace 8 años 4 meses
alta: 12/01/2011 - 18:29
Puntos: 35
arrastrar funciones pero solo modificar una variable

Bueno amigos, a ver si me podeis solucionr este tema

 

Tengo un libro de excel, y en una hoja introduzco las ventas por caja, cada una de ellas, numeradas y ordenadas por fecha.

La cuestión es que luego en otra hoja quiero desglosar las cajas de cada dia, por lo que hago otra tabla que en el primer campo tiene una lista por fechas.   Así yo pretendía que me sumase  en una columna me sumase todas las ventas que coincidieran con la fecha de esa fila, y pensé hacerlo usando esta función

=SUMAR.SI(hoja1!B2:B105;A3:A33;hoja1!G2:G105)

Sinceramente, no entiendo porque el parámetro intermedio ha de ser así, pues yo querría hacerlo de otro modo, comparando A3=hoja1!A3

 

Bueno, ya lo tengo hecho, y aquí viene la cuestión:

Cuando arrastro la crucecita negra inferior derecha (o copio y pego) me arrastra todas las variables cambiandomelas (lo que es muy práctico en otras circunstancias), pero yo querría conservarlas.   ¿Que puedo hacer?

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 8 horas 37 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10025
referencia absoluta

Lo que no quieras que se modifique tienes que ponerlo como referencia absoluta

si en vez de la celda A1, pones la celda $A$1, al extender la fórmula, siempre permanece $A$1.

para cambiar la referencia, sitúate en la fórmula sobre ella y pulsa F4

en este foro hay varios temas con ejemplos de referencias relativas y absolutas, mira aquí

------
Ya sé Excel, pero necesito más ahora en pdf

 

Data Tools Suite
datos y tablas con Excel

PABLITO
Imagen de PABLITO
Offline
última acción: Hace 8 años 4 meses
alta: 12/01/2011 - 18:29
Puntos: 35
Re: referencia absoluta

MUCHAS GRACIAS!!!

Parece que funciona.

dparadap
Imagen de dparadap
Offline
última acción: Hace 10 meses 3 semanas
Nivel 1 - 200 puntos
alta: 16/07/2010 - 14:55
Puntos: 285
Re: referencia absoluta

Pues si esto te parece alucinante, ¡verás cuando descubras las tablas dinámicas!

visitante (no verificado)
Imagen de visitante
Re: referencia absoluta

¿Qué es eso?   Funciona en excel 2003?   Es que tengo licencia original, pero es del office 2003 solo.

pacomegia
Imagen de pacomegia
Offline
última acción: Hace 8 horas 37 mins
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntosadministrador
alta: 27/12/2006 - 23:26
Puntos: 10025
las tablas dinámicas llevan mucho tiempo

Las tablas dinámicas llevan con Excel desde hace mucho tiempo,
tu versión 2003 por supuesto que las tiene.

------
Ya sé Excel, pero necesito más ahora en pdf

 

Data Tools Suite
datos y tablas con Excel