Aplicar formula a celda especifica referenciada en otra celda

4 envíos / 0 nuevos
Último envío
Felipekrebs93
Imagen de Felipekrebs93
Offline
última acción: Hace 2 semanas 1 día
alta: 05/02/2019 - 12:13
Puntos: 185
Aplicar formula a celda especifica referenciada en otra celda

Es muy simple mi consula, supongamos que tengo esta matriz de datos

1-200

2-300

3-100

4-250

5-300

6-700

Cómo puedo hacer para que en otras dos celdas yo tengo esto

Celda   Monto a agregar

Entonces supongamos un ejemplo, yo quiero que si en Celda coloco "4" y en monto a agregar pongo 500, "momentaneamente" al 250 le agregue 500, esto porque con los datos que tengo calculo ciertos indicadores, y quiero ir probando por celda que es lo que pasaría si modifico un dato como afecta en el indicador sin tener que estar modificando las formulas de los montos cada vez que quiero cambiar algo.

Cron
Imagen de Cron
Offline
última acción: Hace 4 días 22 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 11835
Puedes poner 3 celdas. Una

Puedes poner 3 celdas. Una para poner el 4, otra para poner el 500 y otra para poner el total. Por lo tanto, las dos primeras celdas estarán vacías y las podrás editar como quieras. Supongamos que son las celdas A1, B1. En C1 pondríamos la fórmula.

Si los datos están en las celdas A5:B10, podemos poner la siguiente fórmula en C1:

=B1 + BUSCARV(A1;A5:B10;2;0)

De esta manera, en la celda C1 sumará lo que pongas en B1 + Lo que encuentre en la tabla que corresponda con A1.

Un saludo

Felipekrebs93
Imagen de Felipekrebs93
Offline
última acción: Hace 2 semanas 1 día
alta: 05/02/2019 - 12:13
Puntos: 185
No me sirve esa forma, lo que

No me sirve esa forma, lo que necesito es que cambie el valor de la tabla original, porque en la tabla original hay mas columnas y cosas, entonces necesito que vaya cambiando directamente en la tabla, para que cuando cambie, el resto de cosas que también usa esa celda, cambién también. Hay alguna manera?

Cron
Imagen de Cron
Offline
última acción: Hace 4 días 22 horas
Nivel 1 - 200 puntosNivel 2 - 500 puntosNivel 3 - 1000 puntosNivel 4 - 2000 puntosNivel 5 - 4000 puntos
alta: 23/06/2010 - 12:30
Puntos: 11835
En cualquier caso, en tu

En cualquier caso, en tu tabla original debes tener los datos iniciales (que pueden estar en una columna oculta) y los datos calculados. Imaginemos que hacemos lo mismo que antes: En A1 ponemos 4, y en B1 ponemos 500

En A5:B10 tendremos los datos, pero en realidad estarán en A5:C10. En la columna A ponemos el código (1, 2, 3, 4...), en la columna B ponemos los valores iniciales y en la columna C ponemos el valor calculado. Sería con esta fórmula:

=SI(A5=$A$1;$B$1 + B5;B5)

Esta fórmula la copias en C5 y arrastras hacia abajo.

Una alternativa podría ser la siguiente:

=B5 + (A5=$A$1)*$B$1

De la misma manera, arrastra hacia abajo.

Espero que esta sí te sirva.

 

Un saludo